Bug 1308459 - [RFE] Access to API using only session id
[RFE] Access to API using only session id
Status: CLOSED DUPLICATE of bug 1308458
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk-java (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Hernández
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 04:46 EST by Gonza
Modified: 2016-02-16 02:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 02:28:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gonza 2016-02-15 04:46:53 EST
Description of problem:
Currently the API has support for passing session id as a parameter but username and password are still required.
We would like to have the ability of accessing the API without needing to input username and password when we are passing the session id.

Version-Release number of selected component (if applicable):
rhevm-sdk-java-3.6.2.0-2.el6ev.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. Try to access API using only session ID

Actual results:
Username and password are required

Expected results:
We can access the API only passing session id to the constructor.
Comment 1 Gonza 2016-02-15 04:48:55 EST
Wrong version-release, correct one:
rhevm-sdk-python-3.6.2.1-2.el6ev.noarch.rpm
Comment 2 Oved Ourfali 2016-02-16 02:28:49 EST

*** This bug has been marked as a duplicate of bug 1308458 ***

Note You need to log in before you can comment on or make changes to this bug.