Bug 1308460 - [RFE] Access to API using only session id (Python SDK)
[RFE] Access to API using only session id (Python SDK)
Status: CLOSED DUPLICATE of bug 1285887
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk-python (Show other bugs)
3.6.2
Unspecified Unspecified
medium Severity unspecified
: ovirt-4.0.0-alpha
: ---
Assigned To: Juan Hernández
Gonza
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 04:48 EST by Gonza
Modified: 2016-04-07 06:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 06:44:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gonza 2016-02-15 04:48:08 EST
Description of problem:
Currently the API has support for passing session id as a parameter but username and password are still required.
We would like to have the ability of accessing the API without needing to input username and password when we are passing the session id.

Version-Release number of selected component (if applicable):
rhevm-sdk-java-3.6.2.0-2.el6ev.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. Try to access API using only session ID

Actual results:
Username and password are required

Expected results:
We can access the API only passing session id to the constructor.
Comment 1 Gonza 2016-02-25 04:01:20 EST
Wrong version-release on last comment, this should be for:
rhevm-sdk-python-3.6.2.0-1.el6ev.noarch
Comment 2 Juan Hernández 2016-04-07 06:44:42 EDT
Version 4 of the SDK will support SSO, so instead of a session id it will use the SSO token. Closing as duplicate of the RFE to add SSO authentication.

*** This bug has been marked as a duplicate of bug 1285887 ***

Note You need to log in before you can comment on or make changes to this bug.