Bug 1308462 - Failure to create multi-attach volume using Netapp as back-end
Failure to create multi-attach volume using Netapp as back-end
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Eric Harney
nlevinki
: Reopened, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 04:49 EST by lkuchlan
Modified: 2017-04-12 09:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-12 09:38:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1545669 None None None 2016-02-15 05:44 EST

  None (edit)
Description lkuchlan 2016-02-15 04:49:18 EST
Description of problem:
Create a volume as multi-attach is failed with "No valid host was found. No weighed hosts available" using Netapp back-end   

Version-Release number of selected component (if applicable):
python-cinder-7.0.1-5.el7ost.noarch
openstack-cinder-7.0.1-5.el7ost.noarch
python-cinderclient-1.4.0-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Configure Netapp as back-end
2. Create a multi-attach volume 
   

Actual results:
Creating a multi-attach volume is failed

Expected results:
Creating a multi-attach volume should succeed 

Additional info:

[stack@instack ~]$ cinder create 1 --allow-multiattach --volume-type netapp1


[stack@instack ~]$ cinder show de99494c-8e5c-440a-83cc-ed43fd2a43a5
+---------------------------------------+--------------------------------------+
|                Property               |                Value                 |
+---------------------------------------+--------------------------------------+
|              attachments              |                  []                  |
|           availability_zone           |                 nova                 |
|                bootable               |                false                 |
|          consistencygroup_id          |                 None                 |
|               created_at              |      2016-02-14T07:50:03.000000      |
|              description              |                 None                 |
|               encrypted               |                False                 |
|                   id                  | de99494c-8e5c-440a-83cc-ed43fd2a43a5 |
|                metadata               |                  {}                  |
|            migration_status           |                 None                 |
|              multiattach              |                 True                 |
|                  name                 |                 None                 |
|         os-vol-host-attr:host         |                 None                 |
|     os-vol-mig-status-attr:migstat    |                 None                 |
|     os-vol-mig-status-attr:name_id    |                 None                 |
|      os-vol-tenant-attr:tenant_id     |   3a85e4a722e64171be1f495f3c47ccc8   |
|   os-volume-replication:driver_data   |                 None                 |
| os-volume-replication:extended_status |                 None                 |
|           replication_status          |               disabled               |
|                  size                 |                  1                   |
|              snapshot_id              |                 None                 |
|              source_volid             |                 None                 |
|                 status                |                error                 |
|                user_id                |   895a2cab60e449939bc1764458f305a3   |
|              volume_type              |               netapp1                |
+---------------------------------------+--------------------------------------+

From scheduler log:

2016-02-11 09:45:43.669 2798 ERROR cinder.scheduler.flows.create_volume [req-cdd32b70-dc44-4d78-8b71-dbfb201ba3ae 895a2cab60e449939bc1764458f305a3 3a85e4a722e64171be1f495f3c47ccc8 - - -] Failed to run task cinder.scheduler.flows.create_volume.ScheduleCreateVolumeTask;volume:create: No valid host was found. No weighed hosts available
2016-02-11 09:45:43.670 2798 DEBUG cinder.volume.flows.common [req-cdd32b70-dc44-4d78-8b71-dbfb201ba3ae 895a2cab60e449939bc1764458f305a3 3a85e4a722e64171be1f495f3c47ccc8 - - -] Updating volume: 2cd7a5e4-d8a6-49b7-92db-8ae15cd744e2 with {'status': 'error'} due to: No valid host was found. No weighed hosts available _update_object /usr/lib/python2.7/site-packages/cinder/volume/flows/common.py:87
Comment 1 Eric Harney 2016-02-15 10:12:45 EST
None of the NetApp drivers declare support for multiattach yet, so I think this is expected behavior.
Comment 2 David Hill 2016-11-15 19:42:03 EST
Are we sure it's not supported here?  I'm looking at the Liberty code for cinder and it seems like the eseries support multiattach but by default it's disabled and needs to be enabled?
Comment 3 Eric Harney 2017-04-12 09:38:52 EDT
We are not supporting multi-attach as an OSP8 feature.

Note You need to log in before you can comment on or make changes to this bug.