This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1308473 - Couldn't upgrade from v3.0.0.1 to v3.0.2.0
Couldn't upgrade from v3.0.0.1 to v3.0.2.0
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Scott Dodson
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 05:13 EST by Anping Li
Modified: 2017-08-24 16:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-24 16:48:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2016-02-15 05:13:28 EST
Description of problem:
Couldn't upgrade from v3.0.0.1 to v3.0.2.0, the upgrade failed at step "oadm policy reconcile-cluster-roles --confirm"

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.0.40-1.git.22.da21865.el7aos.noarch

How reproducible:
always

Steps to Reproduce:
1.ansible-playbook -i  /root/config/ose3020 /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_0_minor/upgrade.yml
2.
3.
ansible-playbook -i  /root/config/ose3020 /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_0_minor/upgrade.yml


TASK: [oadm policy reconcile-cluster-roles --confirm] ************************* 
failed: [10.14.6.120] => {"changed": true, "cmd": ["oadm", "--config=/etc/openshift/master/admin.kubeconfig", "policy", "reconcile-cluster-roles", "--confirm"], "delta": "0:00:00.044817", "end": "2016-02-15 18:04:48.997194", "rc": 1, "start": "2016-02-15 18:04:48.952377", "warnings": []}
stderr: Error: unknown flag: --confirm
Run 'oadm help' for usage.

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/upgrade.retry

10.14.6.120                : ok=323  changed=33   unreachable=0    failed=1   
10.14.6.126                : ok=113  changed=13   unreachable=0    failed=0   
localhost                  : ok=25   changed=0    unreachable=0    failed=0   


Expected results:


Additional info:
Comment 1 Brenton Leanhardt 2016-02-15 11:35:09 EST
Wow, great catch.  I suspect at this point most customers are upgrading directly to 3.1 which is why this was never reported.  Looking at git it seems this has been broken since Nov.  I think we should fix this but it's definitely not a 3.2 blocker.

Note You need to log in before you can comment on or make changes to this bug.