Bug 1308486 - Base channel selection field has every item twice
Base channel selection field has every item twice
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
2.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2016-02-15 06:06 EST by Lukáš Hellebrandt
Modified: 2017-09-28 14:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-backend-2.5.24-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 04:10:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukáš Hellebrandt 2016-02-15 06:06:04 EST
Description of problem:
Base channel selection field has each channel listed twice

How reproducible:
Deterministic

Steps to Reproduce:
1. Create a channel
2. Systems -> Activation Keys -> Create Key (OR Channels -> Manage Software Channels -> Create Channel)
3. Try to choose base channel (OR parent channel), notice the channel is listed twice

Actual results:
Each channel is listed twice

Expected results:
One channel is enough
Comment 1 Jan Dobes 2016-03-03 12:59:43 EST
Hello, I was not able to reproduce it with your steps.

But I accidentally hit this problem when I was syncing previously exported custom channel using satellite-sync. Channels were listed twice and even were visible from different organization.

I think this bug was not on Spacewalk 2.4.

fixed in spacewalk master:

30941c300ba36abb69273f825f587b4ac7180540
5a7f2904fd5a6dbd409434557c7b4dd075ee22ed
Comment 2 Tomáš Kašpárek 2016-06-16 04:10:54 EDT
Spacewalk 2.5 was released.
Comment 3 Eric Herget 2017-09-28 14:10:43 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.