Bug 1308515 - Missing installonlypkg(kernel) provide in kernel package
Missing installonlypkg(kernel) provide in kernel package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 07:50 EST by Michal Luscon
Modified: 2016-05-26 15:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 15:24:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Luscon 2016-02-15 07:50:46 EST
Please add installonlypkg(kernel) provide into kernel-pae subpackage.
Comment 1 Josh Boyer 2016-02-15 08:40:40 EST
(In reply to Michal Luscon from comment #0)
> Please add installonlypkg(kernel) provide into kernel-pae subpackage.

Please remind me what isntallonlypkg means, and why this would be needed.  Also, why only the kernel-pae subpackage and not all main kernel packages?
Comment 2 Michal Luscon 2016-02-15 09:42:28 EST
It is meant to be a hint for dnf that a package contains kernel and therefore it should be treated as installonly (http://dnf.readthedocs.org/en/latest/conf_ref.html#installonlypkgs-label). You are right that all kernel subpackages providing kernel which are not explicitly named kernel should contain installonlypkg(kernel) provide.

I mentioned kernel-pae just because of https://bugzilla.redhat.com/show_bug.cgi?id=1306057 for the big picture .
Comment 3 Josh Boyer 2016-02-15 09:55:04 EST
(In reply to Michal Luscon from comment #2)
> It is meant to be a hint for dnf that a package contains kernel and
> therefore it should be treated as installonly
> (http://dnf.readthedocs.org/en/latest/conf_ref.html#installonlypkgs-label).
> You are right that all kernel subpackages providing kernel which are not
> explicitly named kernel should contain installonlypkg(kernel) provide.

So, it seems we keep piling on hacks here.  DNF is hardcoded to look for kernel, and that's it.  Why would we keep adding installonlypkg to every kernel subpackage that gets added just to work around DNF's hardcoding?

Wouldn't it be better to simply add installonlypkg to all the kernel packages and just rely on that?  It seems less error prone in the long run.

Also, from an implementation standpoint we're going to have to do that anyway due to the way that we generate the main kernel packages from the spec file.
Comment 4 Justin M. Forbes 2016-02-17 16:08:04 EST
This has been added to rawhide for the moment, it should trickle down as releases get rebased, but since it changes the way updates are handled, I don't want to push it everywhere immediately.
Comment 5 Josh Boyer 2016-05-26 15:24:47 EDT
We did this as Justin said, but there are related issues in dnf because of this.  That is being tracked in bug 1333591

Note You need to log in before you can comment on or make changes to this bug.