This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1308537 - Atomic Developer Mode
Atomic Developer Mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jonathan Lebon
ChangeAcceptedF24, SelfContainedChange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 08:19 EST by Jan Kurik
Modified: 2016-09-29 07:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-29 07:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-02-15 08:19:52 EST
This is a tracking bug for Change: Atomic Developer Mode
For more details, see: https://fedoraproject.org//wiki/Changes/Atomic_Developer_Mode

Add a "Developer Mode" boot menu entry in the Atomic image to allow users to boot without setting up cloud-init.
Comment 1 Jan Kurik 2016-02-24 09:26:11 EST
On 2016-Feb-23, we have reached Fedora 24 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo on 2016-Feb-26 meeting.  Contingency plan for System Wide Changes, if planned for Alpha (or in case of serious doubts regarding Change completion), will be activated.
Comment 2 Jan Kurik 2016-04-20 11:01:39 EDT
On 2016-Apr-19 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 24 release. At this point all the Changes not at least in in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan
Comment 3 Jonathan Lebon 2016-04-20 11:53:33 EDT
AFAICT, I can't test this because we're not currently building F24 Atomic images with F24 content, is that correct?

As a test, looking at the latest compose[1], the Fedora-Atomic-24 image greets me with a F25/rawhide build. (Whereas the Fedora-Cloud-Base-24 image is correct).

Or is there an F24 two-week release stream being published somewhere else?

[1] https://kojipkgs.fedoraproject.org/compose//branched/Fedora-24-20160420.n.0/compose/CloudImages/x86_64/images/
Comment 4 Jan Kurik 2016-04-21 05:09:57 EDT
Hopefully Kushal will know the right answer for this.
Comment 5 Jan Kurik 2016-04-22 12:48:32 EDT
Looks like here is the answer about F24 Atomic Images: https://lists.fedoraproject.org/archives/list/cloud@lists.fedoraproject.org/message/6LUVFAPRWPGFVFOZ5X7IXE5Q4V636UY3/
Comment 6 Jonathan Lebon 2016-04-25 14:56:21 EDT
Thanks for the link Jan. I answered to that email on the list here:
https://lists.fedoraproject.org/archives/list/cloud@lists.fedoraproject.org/message/GRV36LGLKHQKYG3MWQEEGMZPXVVUYBGN/

Hopefully someone can clear this up.
Comment 7 Jonathan Lebon 2016-05-02 10:03:28 EDT
Looks like this was fixed recently, so I'll be able to test it soon.
https://fedorahosted.org/rel-eng/ticket/6407
Comment 8 Jonathan Lebon 2016-05-03 22:27:00 EDT
Change working mostly fine. There are some issues that have already been addressed in this update:

https://bodhi.fedoraproject.org/updates/FEDORA-2016-9970a9aaa0

which I'm hoping will make it in before the Beta Release.

Will just put this in ON_QA.

Note You need to log in before you can comment on or make changes to this bug.