Bug 1308543 - [abrt] hamster-time-tracker: __init__.py:52:__init__:AttributeError: 'NoneType' object has no attribute 'strip'
[abrt] hamster-time-tracker: __init__.py:52:__init__:AttributeError: 'NoneTyp...
Status: CLOSED DUPLICATE of bug 1181438
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ankur Sinha (FranciscoD)
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-02-15 08:25 EST by Matej
Modified: 2016-02-15 08:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-02-15 08:50:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (698 bytes, text/plain)
2016-02-15 08:25 EST, Matej
no flags Details
File: environ (1.47 KB, text/plain)
2016-02-15 08:25 EST, Matej
no flags Details

  None (edit)
Description Matej 2016-02-15 08:25:31 EST
Version-Release number of selected component:

Additional info:
reporter:       libreport-2.6.4
cmdline:        python /usr/bin/hamster
executable:     /usr/bin/hamster
kernel:         4.3.5-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
__init__.py:52:__init__:AttributeError: 'NoneType' object has no attribute 'strip'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/hamster/today.py", line 451, in on_switch_activity_clicked
    tags = self.new_tags.get_text().decode("utf8", "replace"))
  File "/usr/lib/python2.7/site-packages/hamster/lib/__init__.py", line 52, in __init__
    input_parts = activity.strip().split(" ")
AttributeError: 'NoneType' object has no attribute 'strip'

Local variables in innermost frame:
category: ''
activity_id: None
description: ''
tags: u''
start_time: None
activity: None
self: <hamster.lib.Fact object at 0x7f2e227690d0>
end_time: None
delta: None
date: None
id: None

Potential duplicate: bug 1181438
Comment 1 Matej 2016-02-15 08:25:39 EST
Created attachment 1127277 [details]
File: backtrace
Comment 2 Matej 2016-02-15 08:25:42 EST
Created attachment 1127278 [details]
File: environ
Comment 3 Raphael Groner 2016-02-15 08:50:33 EST
Hi Matej,

thanks for your report. Please try to reproduce with the new update version 2.0 rc1. You will get it by executing the following command:

 dnf update hamster-time-tracker

This bug is known since Fedora 20, at least ...

*** This bug has been marked as a duplicate of bug 1181438 ***

Note You need to log in before you can comment on or make changes to this bug.