Bug 1308560 - wrong number of disks during cluster expand
wrong number of disks during cluster expand
Status: CLOSED ERRATA
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity medium
: ---
: 2
Assigned To: sankarshan
Lubos Trilety
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 08:58 EST by Lubos Trilety
Modified: 2016-08-23 15:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: rhscon-ui-0.0.23-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:46:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
expand tab screen-shot (78.02 KB, image/png)
2016-02-15 08:58 EST, Lubos Trilety
no flags Details
skyring reply on client request about un-managed nodes (5.66 KB, text/plain)
2016-02-15 09:01 EST, Lubos Trilety
no flags Details

  None (edit)
Description Lubos Trilety 2016-02-15 08:58:42 EST
Created attachment 1127292 [details]
expand tab screen-shot

Description of problem:
When cluster is expanded it counts all disks on machines even those which are already used. Note that they are not counted during cluster creation.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-2.el7.x86_64
rhscon-ceph-0.0.6-2.el7.x86_64
rhscon-ui-0.0.11-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create some cluster and then tries to expand it.
2. Look on suggested nodes.

Actual results:
There is a bad number for available disks.

Expected results:
Only unused disks will be counted as for cluster creation.

Additional info:
Note on attached screen-shot those machines have only one disk unused.
Comment 1 Lubos Trilety 2016-02-15 09:01 EST
Created attachment 1127295 [details]
skyring reply on client request about un-managed nodes
Comment 5 Lubos Trilety 2016-08-01 10:58:35 EDT
Tested on:
rhscon-core-0.0.38-1.el7scon.x86_64
rhscon-ceph-0.0.38-1.el7scon.x86_64
rhscon-core-selinux-0.0.38-1.el7scon.noarch
rhscon-ui-0.0.51-1.el7scon.noarch
Comment 7 errata-xmlrpc 2016-08-23 15:46:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754

Note You need to log in before you can comment on or make changes to this bug.