Bug 1308593 - redhat-support-tool should depend on python-magic
redhat-support-tool should depend on python-magic
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-support-tool (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mark Huth
Petr Šplíchal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 10:03 EST by Filip Holec
Modified: 2016-05-31 21:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 21:26:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Holec 2016-02-15 10:03:54 EST
Description of problem:
If there is fresh installation of redhat-support-tool - for example on our internal servers - and package python-magic is not installed, backtrace will appear. That package should be installed with redhat-support-tool (and *-lib-python as well).

Version-Release number of selected component (if applicable):
redhat-support-tool-0.9.8-3.el6

How reproducible:
Always

Steps to Reproduce:
1.redhat-support-tool diagnose /var/log/messages

Actual results:
Traceback (most recent call last):
  File "/usr/bin/redhat-support-tool", line 21, in <module>
    from redhat_support_tool.helpers.common import set_docstring
  File "/usr/lib/python2.6/site-packages/redhat_support_tool/helpers/common.py", line 25, in <module>
    from redhat_support_tool.helpers.soscleaner import SOSCleaner
  File "/usr/lib/python2.6/site-packages/redhat_support_tool/helpers/soscleaner.py", line 27, in <module>
    import magic
ImportError: No module named magic

Expected results:
Command passes without any problem

Additional info:
We should be able to fix and verify this issue in rhel-6.8 release.
Comment 10 errata-xmlrpc 2016-05-10 21:26:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0969.html

Note You need to log in before you can comment on or make changes to this bug.