Bug 1308606 - iburst missing from /etc/chrony.conf
iburst missing from /etc/chrony.conf
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
All Linux
high Severity medium
: GA
: 5.6.0
Assigned To: Yuri Rudman
luke couzens
appliance:ntp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 10:27 EST by David La Motta
Modified: 2017-08-30 04:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:41:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David La Motta 2016-02-15 10:27:06 EST
Description of problem:

After configuring NTP servers via the appliance_console and/or the user interface, the server entries in /etc/chrony.conf are missing iburst.  

Version-Release number of selected component (if applicable):

5.5.2.4.20160127105142_395c086


How reproducible:

100%

Steps to Reproduce:
1. Configure new CFME appliance
2. Modify NTP servers via web user interface

Actual results:

/etc/chrony.conf reads:

...
server 0.rhel.pool.ntp.org
server 1.rhel.pool.ntp.org
...


Also, when running timedatectl the output shows:

...
     NTP enabled: yes
NTP synchronized: no
...


Expected results:

/etc/chrony.conf reads:

...
server 0.rhel.pool.ntp.org iburst
server 1.rhel.pool.ntp.org iburst
...


When running timedatectl the output shows:

...
     NTP enabled: yes
NTP synchronized: yes
...



Additional info:

In order to force time sync to take place, an 'ntpdate pool.ntp.org' can be triggered to get the system up to date after adding 'iburst' to the /etc/chrony.conf file by hand.

This problem caused an Azure provider from failing to sync and connect:

[----] E, [2016-02-12T17:09:31.767792 #29726:d1d990] ERROR -- : MIQ(ManageIQ::Providers::Azure::CloudManager::Refresher#refresh) EMS: [Azure], id: [1000000000006] Refresh failed

[----] E, [2016-02-12T17:09:31.768129 #29726:d1d990] ERROR -- : [Azure::Armrest::UnauthorizedException]: The access token expiry UTC time '2/13/2016 2:37:51 AM' is earlier than current UTC time '2/13/2016 12:20:59 PM'.  Method:[rescue in block in refresh]

[----] E, [2016-02-12T17:09:31.768309 #29726:d1d990] ERROR -- : /opt/rh/cfme-gemset/gems/azure-armrest-0.0.8/lib/azure/armrest/armrest_service.rb:337:in `raise_api_exception'

[----] E, [2016-02-12T17:09:31.768401 #29726:d1d990] ERROR -- : MIQ(ManageIQ::Providers::Azure::CloudManager::Refresher#refresh) EMS: [Azure], id: [1000000000006] Unable to perform refresh for the following targets:

[----] E, [2016-02-12T17:09:31.768535 #29726:d1d990] ERROR -- : MIQ(ManageIQ::Providers::Azure::CloudManager::Refresher#refresh)  --- ManageIQ::Providers::Azure::CloudManager [Azure] id [1000000000006]

[----] I, [2016-02-12T17:10:25.864116 #29738:561990]  INFO -- : Q-task_id([log_status]) MIQ(MiqServer.log_system_status) [EVM Server (29555)] MiqQueue count for state=["error"] by zone and role: {"default"=>{nil=>5}}
Comment 4 CFME Bot 2016-02-25 10:20:08 EST
New commit detected on ManageIQ/linux_admin/master:
https://github.com/ManageIQ/linux_admin/commit/3b099021a4d23c94418678fb217de07d5c6af50c

commit 3b099021a4d23c94418678fb217de07d5c6af50c
Author:     Yuri Rudman <yrudman@redhat.com>
AuthorDate: Thu Feb 18 11:26:37 2016 -0500
Commit:     Yuri Rudman <yrudman@redhat.com>
CommitDate: Wed Feb 24 15:01:32 2016 -0500

    Added iburst parameter while setting  ntp servers
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1308606
    
    Modified chrony_spec to check iburst parameter while adding ntp servers

 lib/linux_admin/chrony.rb | 2 +-
 spec/chrony_spec.rb       | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 7 CFME Bot 2016-02-29 17:55:53 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/e7df677bb29a18fdcb2982a75a8aeabc9c181487

commit e7df677bb29a18fdcb2982a75a8aeabc9c181487
Author:     Yuri Rudman <yrudman@redhat.com>
AuthorDate: Fri Feb 19 16:23:54 2016 -0500
Commit:     Yuri Rudman <yrudman@redhat.com>
CommitDate: Mon Feb 29 16:37:12 2016 -0500

    Bump linux_admin gem to version 0.16.0
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1308606
    PR: ManageIQ/linux_admin#157

 gems/pending/Gemfile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 Yuri Rudman 2016-03-02 14:04:13 EST
PR: ManageIQ/linux_admin#157
Comment 9 Jeff Teehan 2016-03-28 13:35:42 EDT
Working correctly on Beta 1 build.  Moving to Verified.  Test steps below.

##START TEST
[root@10-16-6-154 ~]# timedatectl
      Local time: Mon 2016-03-28 13:29:02 EDT
  Universal time: Mon 2016-03-28 17:29:02 UTC
        RTC time: Mon 2016-03-28 17:34:25
       Time zone: America/New_York (EDT, -0400)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  Sun 2016-03-13 01:59:59 EST
                  Sun 2016-03-13 03:00:00 EDT
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  Sun 2016-11-06 01:59:59 EDT
                  Sun 2016-11-06 01:00:00 EST
[root@10-16-6-154 ~]# date
Mon Mar 28 13:29:05 EDT 2016

##CHANGE DATE TIME

[root@10-16-6-154 ~]# date --set="2 OCT 2006 18:00:00"
Mon Oct  2 18:00:00 EDT 2006
[root@10-16-6-154 ~]# date
Mon Oct  2 18:00:03 EDT 2006

## RUN NTPD

[root@10-16-6-154 ~]# ntpd -gq
ntpd: time set +299359808.817328s

## CHECKED DATE TIME

[root@10-16-6-154 ~]# date
Mon Mar 28 13:32:18 EDT 2016
[root@10-16-6-154 ~]# timedatectl
      Local time: Mon 2016-03-28 13:32:31 EDT
  Universal time: Mon 2016-03-28 17:32:31 UTC
        RTC time: Mon 2016-03-28 17:37:53
       Time zone: America/New_York (EDT, -0400)
     NTP enabled: yes
NTP synchronized: no
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  Sun 2016-03-13 01:59:59 EST
                  Sun 2016-03-13 03:00:00 EDT
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  Sun 2016-11-06 01:59:59 EDT
                  Sun 2016-11-06 01:00:00 EST
[root@10-16-6-154 ~]#
Comment 11 errata-xmlrpc 2016-06-29 11:41:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.