Bug 1308616 - Not possible to select values using "is contained in the" operator
Not possible to select values using "is contained in the" operator
Status: CLOSED DUPLICATE of bug 1304140
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: manstis
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 10:51 EST by Anton Giertli
Modified: 2016-02-15 11:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 11:14:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[0] git repository containing all the assets (133.18 KB, application/zip)
2016-02-15 10:53 EST, Anton Giertli
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2162111 None None None 2016-02-15 11:00 EST

  None (edit)
Description Anton Giertli 2016-02-15 10:51:53 EST
Description of problem:

If you create Enumeration (via New -> Enumeration) and then author a rule (for example using Guided Decision Table), which is using operator "is contained in the", it is not possible to select and confirm the values from this Enumaration

Version-Release number of selected component (if applicable):
BRMS 6.2.0
BPM Suite 6.2.0

How reproducible:
always

Steps to Reproduce:
1. Create Data Model, Create Enumeration on one of the Model's attributes
2. Create Guided Decision Table against this attribute
3. Use "is contained in" operator on this column and try to select some values from the enum

Actual results:
It is not possible to select values using "is contained in" operator

Expected results:
It is possible to select values using "is contained in" operator

Additional info:
The workaround is to define the enumeration *inside* the Guided Decision Table - manually. But this is inconvenient, because users can't reuse the Enumeration created outside of the table amongst different business resources, and instead they are force to create the Enum manually inside the tables..

Attached is the git repository with everything needed.
Also the video demonstrating this issue.
Comment 1 Anton Giertli 2016-02-15 10:53 EST
Created attachment 1127320 [details]
[0] git repository containing all the assets
Comment 4 manstis 2016-02-15 11:14:57 EST
I suspect this is a duplicate of the referenced BZ.

*** This bug has been marked as a duplicate of bug 1304140 ***

Note You need to log in before you can comment on or make changes to this bug.