This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 130862 - FC3 kernel does not contain the new i915 DRM, no Intel 3D anymore
FC3 kernel does not contain the new i915 DRM, no Intel 3D anymore
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-08-25 07:22 EDT by Julien Olivier
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 04:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/Xorg.0.log (50.63 KB, text/plain)
2004-08-25 07:38 EDT, Julien Olivier
no flags Details

  None (edit)
Description Julien Olivier 2004-08-25 07:22:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
After 08/25's upgrade to rawhide, I lost 3D acceleration on my Intel
852 video card.

3D acceleration did work with FC1 and FC2, though.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.99.902-4

How reproducible:
Always

Steps to Reproduce:
1.Try to run any 3D-enabled application
2.
3.
    

Actual Results:  It's very slow

Expected Results:  It should be faster

Additional info:

[julien@julien ~]$ glxinfo | grep rendering
direct rendering: No


[julien@julien ~]$ cat /etc/X11/xorg.conf
# Xorg configuration created by system-config-display
 
Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
 
Section "Files"
 
# RgbPath is the location of the RGB database.  Note, this is the name
of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection
 
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection
 
Section "InputDevice"
 
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "fr"
EndSection
 
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection
 
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1024x768"
        HorizSync    31.5 - 48.5
        VertRefresh  40.0 - 70.0
        Option      "dpms"
EndSection
 
Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
        VendorName  "Videocard vendor"
        BoardName   "Intel 852"
EndSection
 
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
 
Section "DRI"
        Group        0
        Mode         0666
EndSection
Comment 1 Mike A. Harris 2004-08-25 07:33:38 EDT
Please attach your X server startup log, and /var/log/messages.

When attaching files, please use the bugzilla file attachment
feature to attach uncompressed files that can be clicked on in
a web browser, as it makes it easier to view the bug report
that way.

Thanks in advance.
Comment 2 Julien Olivier 2004-08-25 07:38:35 EDT
Created attachment 103066 [details]
/var/log/Xorg.0.log

Is this the right file ?
Comment 3 Julien Olivier 2004-08-25 07:44:20 EDT
/var/log/messages is too large. Which part should I send ?
Comment 4 Julien Olivier 2004-08-25 08:09:35 EDT
I put the whole /var/log/messages on my web server:

http://www.toufle.net/julien/messages
Comment 5 Mike A. Harris 2004-08-25 10:37:47 EDT
>[drm] failed to load kernel module "i915"
>(II) I810(0): [drm] drmOpen failed
>(EE) I810(0): [dri] DRIScreenInit failed. Disabling DRI.

You do not have the i915 kernel DRM module in your kernel.  Make
sure you are running the absolute latest rawhide kernel.

Reassigning to kernel component to ensure our current rawhide kernel
has the i915 DRM module.  Once that's confirmed this can be closed
"NOTABUG" or "RAWHIDE" depending...

Comment 6 Mike A. Harris 2004-08-25 10:39:47 EDT
The 'messages' file is way too large to view.  All that is needed
is starting from boot time onward.  
Comment 7 Julien Olivier 2004-08-25 11:18:58 EDT
According to those commands, my kernel is 2.6.8-1.526, which is the
latest kernel I got from up2date.

[julien@julien ~]$ rpm -q kernel
kernel-2.6.6-1.435.2.1
kernel-2.6.8-1.526
[julien@julien ~]$ uname -r
2.6.8-1.526
Comment 8 Mike A. Harris 2004-08-25 11:39:43 EDT
Our kernel does not have the "i915" DRM kernel module it appears.
Without the "i915" kernel module, all Intel video hardware including
i830, i845, i852, i855, i865, and i915 will no longer have DRI
3D acceleration support.

This is a serious kernel issue that we need to resolve for FC3
test 2 release, or else the new i915 DRM will not get adequate
user testing and stabilization.
Comment 9 Julien Olivier 2004-08-27 03:51:53 EDT
That said,

[julien@julien ~]$ locate i915
/usr/X11R6/lib/modules/dri/i915_dri.so

Does it mean the i915 DRM module really is in the kernel ? If so, why
can't it be loaded ?
Comment 10 Mike A. Harris 2004-08-27 05:25:56 EDT
/usr/X11R6/lib/modules/dri/* contains the Mesa DRI 3D drivers.  These
are opened by libGL when you run an OpenGL application.  These are
userland GL drivers, not kernel DRM modules.

All kernel modules are in "/lib/modules/*".

The reason you can't load i915 kernel module, is because we currently
do not ship it.  Once our kernel contains the i915 module, things
should just work automatically without any reconfiguration or
tweaking.
Comment 11 Julien Olivier 2004-08-27 07:28:15 EDT
OK, thanks for the explanation. Just waiting for an updated kernel then :)
Comment 12 Arjan van de Ven 2004-08-30 03:42:56 EDT
kernel is there
Comment 13 Julien Olivier 2004-08-30 04:24:26 EDT
I confirm. I've just tested with 2.6.8-1.533 and 3D acceleration is back.

Thanks !

I guess I can close it "rawhide".

Note You need to log in before you can comment on or make changes to this bug.