Bug 1308625 - [Beaker][inverted group] "INTERNAL SERVER ERROR" When adding a additional owners
[Beaker][inverted group] "INTERNAL SERVER ERROR" When adding a additional owners
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 22.2
: ---
Assigned To: matt jia
tools-bugs
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 11:01 EST by Jeff Burke
Modified: 2016-03-17 20:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 20:45:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of the failure (109.62 KB, image/png)
2016-02-15 11:01 EST, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2016-02-15 11:01:15 EST
Created attachment 1127321 [details]
screen shot of the failure

Description of problem:
 I created a inverted group. I tried to add an additional owner to the group and it fails with the following error:

INTERNAL SERVER ERROR: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN"> <title>500 Internal Server Error</title> <h1>Internal Server Error</h1> <p>The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.</p> 

Attach is a screenshot
Comment 1 Dan Callaghan 2016-02-17 00:59:04 EST
Reproduced on beaker-devel, stack trace is:

bkr.server ERROR Exception on /groups/bz1308625-test/owners/ [POST]
 Traceback (most recent call last):
   File "/usr/lib/python2.6/site-packages/flask/app.py", line 1817, in wsgi_app
     response = self.full_dispatch_request()
   File "/usr/lib/python2.6/site-packages/flask/app.py", line 1477, in full_dispatch_request
     rv = self.handle_user_exception(e)
   File "/usr/lib/python2.6/site-packages/flask/app.py", line 1381, in handle_user_exception
     reraise(exc_type, exc_value, tb)
   File "/usr/lib/python2.6/site-packages/flask/app.py", line 1475, in full_dispatch_request
     rv = self.dispatch_request()
   File "/usr/lib/python2.6/site-packages/flask/app.py", line 1461, in dispatch_request
     return self.view_functions[rule.endpoint](**req.view_args)
   File "/usr/lib/python2.6/site-packages/bkr/server/flask_util.py", line 209, in wrapper
     return f(*args, **kwds)
   File "/usr/lib/python2.6/site-packages/bkr/server/group.py", line 720, in grant_ownership
     group.grant_ownership(user, agent=identity.current.user)
   File "/usr/lib/python2.6/site-packages/bkr/server/model/identity.py", line 707, in grant_ownership
     assoc, = [a for a in self.user_group_assocs if a.user == user]
 ValueError: need more than 0 values to unpack
Comment 2 matt jia 2016-02-22 01:08:25 EST
On gerrit:

   http://gerrit.beaker-project.org/#/c/4693/
Comment 3 Dan Callaghan 2016-03-17 20:45:23 EDT
This fix was actually included in Beaker 22.2 although we missed it because the milestone was not set correctly...

Note You need to log in before you can comment on or make changes to this bug.