This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1308628 - djvu support doesn't work for names without extension
djvu support doesn't work for names without extension
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 11:14 EST by vvs
Modified: 2016-03-26 14:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: evince-3.18.2-4.fc23 evince-3.18.2-5.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-12 06:49:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vvs 2016-02-15 11:14:05 EST
Description of problem:

I can't view djvu documents in evince. The evince-djvu support package is installed.

Version-Release number of selected component (if applicable):

evince-djvu-3.18.2-3

How reproducible:

Always

Steps to Reproduce:
1. Try to open djvu document in evince

Actual results:

File type DjVu document (image/vnd.djvu+multipage) is not supported

Expected results:

It should work.

Additional info:
Comment 1 Marek Kašík 2016-02-15 11:19:55 EST
I can open djvu files on my F23 just fine. Maybe it is related to a specific djvu. Could you point us to one showing the problem?
Comment 2 vvs 2016-02-15 11:51:15 EST
As it turned out that happens when a file name doesn't have an extension. In other case it opened the file and then crashed. That seems to happen with any djvu file I've tried.
Comment 3 vvs 2016-02-15 12:26:30 EST
The crash seems to be random and I can't reproduce it. The only problem is a missing file name extension.
Comment 4 vvs 2016-02-15 13:41:38 EST
This patch fixed the problem:

--- djvudocument.evince-backend~	2015-12-15 19:13:05.000000000 +0200
+++ djvudocument.evince-backend	2016-02-15 20:37:26.587773218 +0200
@@ -80,4 +80,4 @@
 TypeDescription[zh_HK]=DjVu 文件
 TypeDescription[zh_TW]=DjVu 文件
 TypeDescription[zu]=Amadokhumende we-DjVu
-MimeType=image/vnd.djvu;application/x-ext-djv;application/x-ext-djvu;
+MimeType=image/vnd.djvu;image/vnd.djvu+multipage;application/x-ext-djv;application/x-ext-djvu;
Comment 5 Marek Kašík 2016-02-16 06:17:00 EST
Thank you for the hint. This is currently discussed in this upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=754467
Comment 6 Marek Kašík 2016-03-08 12:01:18 EST
I've pushed a fix for this to F23, F24 and rawhide.
Comment 7 Fedora Update System 2016-03-08 12:04:25 EST
evince-3.18.2-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c0bdac228d
Comment 8 Fedora Update System 2016-03-08 12:04:29 EST
evince-3.18.2-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cf8c54609f
Comment 9 Fedora Update System 2016-03-09 17:56:17 EST
evince-3.18.2-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c0bdac228d
Comment 10 Fedora Update System 2016-03-09 20:57:16 EST
evince-3.18.2-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cf8c54609f
Comment 11 Fedora Update System 2016-03-12 06:49:35 EST
evince-3.18.2-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-03-26 14:19:03 EDT
evince-3.18.2-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.