Bug 1308631 - Install of python-polib fails if system has renamed python2-polib
Install of python-polib fails if system has renamed python2-polib
Status: CLOSED DUPLICATE of bug 1096506
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 11:19 EST by Milan Kubík
Modified: 2016-02-22 07:27 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 07:27:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kubík 2016-02-15 11:19:16 EST
Description of problem:
When trying to install a package depending on python-polib on a system that has newer version installed (python2-polib 1.0.7-2) DNF does not recognize the package and creates conflict. 


Actual results:
Error: installed package python2-polib-1.0.7-2.fc23.noarch obsoletes python-polib < 1.0.7-2.fc23 provided by python-polib-1.0.3-6.fc23.noarch
(try to add '--allowerasing' to command line to replace conflicting packages)

Expected results:
dnf doesn't try to erase the newer package

Additional info:
Comment 1 David Shea 2016-02-15 11:23:37 EST
$ rpm -q --provides python2-polib
python-polib = 1.0.7-3.fc24
python2-polib = 1.0.7-3.fc24

So this is either a problem in dnf or something wrong with the %python_provide macro.
Comment 2 Milan Kubík 2016-02-15 11:43:42 EST
It seems I ran into this again. https://bugzilla.redhat.com/show_bug.cgi?id=1096506

Thanks for looking into it.
Comment 3 Honza Silhan 2016-02-22 07:27:19 EST

*** This bug has been marked as a duplicate of bug 1096506 ***

Note You need to log in before you can comment on or make changes to this bug.