Bug 130864 - cdrecord claims that writer supports no writing modes
cdrecord claims that writer supports no writing modes
Status: CLOSED DUPLICATE of bug 130576
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-25 08:02 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2004-08-25 08:02:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Trying to write an ISO image to an ATAPI writer, cdrecord fails to do
so claiming that the writer supports no writing modes:

[sun@nausicaa ~/temp/SMLA :( (1) 19]$ cdrecord dev=/dev/hdc -tao
-dummy foo.iso  
Cdrecord-Clone 2.01a38-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
[snipped]
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c   1
.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : '_NEC    '
Identifikation : 'DVD_RW ND-2500A '   
Revision       : '1.06'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes:
cdrecord: Drive does not support TAO recording.
cdrecord: Illegal write mode for this drive.

The same occurs when passing "-dao" to cdrecord ("cdrecord: Drive does
not support SAO recording."). The drive has worked fine in this machine.
Writing to a SCSI-CDR in the same machine works fine with the same
cdrecord version.
kernel is kernel-2.6.8-1.526

Version-Release number of selected component (if applicable):
cdrecord-2.01.0.a37.99-1

How reproducible:
Always

Steps to Reproduce:
1. Try to write to an ATAPI writer
2.
3.
    

Actual Results:  cdrecord claims no supported writing modes

Expected Results:  Writing to media

Additional info:
Comment 1 Harald Hoyer 2004-08-25 08:23:25 EDT
can you try:
instead of
# cdrecord dev=/dev/hdc -tao
the ATA interface:
# cdrecord dev=ATA:1,0,0 -tao


Comment 2 Ralf Ertzinger 2004-08-25 13:27:34 EDT
The same result (the correct drive is being used).
Comment 3 Ralf Ertzinger 2004-08-27 12:47:32 EDT
The same command works as root.
Comment 4 David Juran 2004-08-28 03:46:44 EDT
This seems to me like a duplicate of bug 130576
Comment 5 Harald Hoyer 2004-08-30 04:16:32 EDT

*** This bug has been marked as a duplicate of 130576 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:05:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.