Bug 1308723 - Root password can't be changed
Root password can't be changed
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: ISO Installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Jason Montleon
Tasos Papaioannou
: Triaged
Depends On:
Blocks: 1327331
  Show dependency treegraph
 
Reported: 2016-02-15 16:05 EST by Thom Carlin
Modified: 2016-09-13 12:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1327331 (view as bug list)
Environment:
Last Closed: 2016-09-13 12:26:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2016-02-15 16:05:05 EST
Description of problem:

During Anaconda, once the root password is set, it cannot be changed.

Version-Release number of selected component (if applicable):

TP2 RC9

How reproducible:

100%

Steps to Reproduce:
1. Install using either RHCI or TripleO ISO
2. In Anaconda, enter root password successfully) so main screen shows "Root password is set"
3. Try to change root password (again)

Actual results:

Unable to change

Expected results:

Able to change

Additional info:

If this is not the desired functionality, please document the restriction.
Comment 1 Dave Johnson 2016-02-17 10:57:49 EST
Thom, how does it work in RHEL installs, can you update the password after setting it?
Comment 2 Thom Carlin 2016-02-17 11:20:58 EST
With RHEL 7.1, after the Root Password is set, YES you can update the password.
Comment 3 John Matthews 2016-02-17 15:00:33 EST
Thom,

This sounds like a pure anaconda thing and not related to anything with the RHCI installer.

Are you saying that behavior is different with our ISO opposed to the RHEL ISO?
Comment 4 Thom Carlin 2016-02-17 15:09:35 EST
I will re-verify during installer shortly
Comment 5 Thom Carlin 2016-02-17 15:30:07 EST
Yes, for RHEL, I tested using the RHEL 7.1 ISO on our RHEVM 3.5 system.  For RHCI and TripleO, I used the TP 2 RC9 ISOs.

RHEL Anaconda allows the root password to change
RHCI/TripleO Anaconda does not.

Could this be tied to the "No user will be created" setting?
Comment 6 Jason Montleon 2016-06-22 09:36:37 EDT
This was most likely due to one ISO being RHEL 7.2 (QCI) and one being 7.1 (OOO). Once we moved to RHEL OSP 8 the ISO was switched to RHEL 7.2.
Comment 7 Tasos Papaioannou 2016-06-23 13:58:24 EDT
Verified on QCI-1.2-RHEL-7-20160621.t.0-QCI and QCIOOO-8.0-RHEL-7-20160617.n.2.
Comment 13 errata-xmlrpc 2016-09-13 12:26:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.