Bug 1308729 - foreman-rake trends:clean doesn't clean the trend_counters table
Summary: foreman-rake trends:clean doesn't clean the trend_counters table
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Other
Version: 6.1.6
Hardware: All
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Chris Roberts
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-15 21:28 UTC by Nagoor Shaik
Modified: 2019-11-14 07:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:01:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Nagoor Shaik 2016-02-15 21:28:33 UTC
Description of problem:
foreman-rake trends:clean doesn't clean the trend_counters table

Version-Release number of selected component (if applicable):
Satellite 6.1.6

How reproducible:
100%

Steps to Reproduce:
1. Create some trends in satellite 6 either by doing a inserting content into Satellite 6 DB directly
2. Execute the command 
     # foreman-rake trends:clean  ---> command would complete successfully, however it wouldn't stop the linear growth of the trend_counters table in postgres DB

 ------------------------------------------------------------------------+----------
public.trend_counters                                                  | 16 GB
public.index_trend_counters_on_trend_id               | 7754 MB
public.trend_counters_pkey                                        | 6016 MB

foreman=# select count(*) from trend_counters;
count
-----------
 288490382
(1 row)

# time foreman-rake trends:counter
real    56m5.516s
user    28m10.714s
sys     0m33.396s

Actual results:
trend_counters table is filling up very fast, with huge number of records in it

Expected results:
trends:clean script should actually clean the old data to save up the disk space 

Additional info:

Comment 2 Ohad Levy 2016-03-07 12:40:39 UTC
trends storage has been rewritten in 6.2, setting on QE as this should already be resolved.

Comment 6 errata-xmlrpc 2016-07-27 09:01:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.