Bug 1308732 - subscription-manager system fact virt.uuid: Unknown is reported on physical systems
subscription-manager system fact virt.uuid: Unknown is reported on physical s...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 16:37 EST by John Sefler
Modified: 2016-05-10 16:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:40:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2016-02-15 16:37:36 EST
Description of problem:
Prior to subscription-manager commit f8416137a3b426aa54608116e005df7273abfada a physical system would not report a "virt.uuid" fact at all.  Now on the latest builds for rhel6.8, physical systems are reporting "virt.uuid: Unknown".

This may be an insignificant change, but it is a change.  Please advise whether I should update the automated test that caught this or you should fix the regression.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
Previous behavior from the subscription-manager on a physical ppc64 system on RHEL67...
[root@ibm-p8-05-lp7 ~]# rpm -q subscription-manager
subscription-manager-1.14.10-1.el6.ppc64
[root@ibm-p8-05-lp7 ~]# virt-what 
[root@ibm-p8-05-lp7 ~]# 
[root@ibm-p8-05-lp7 ~]# subscription-manager facts | grep virt
virt.host_type: Not Applicable
virt.is_guest: False
[root@ibm-p8-05-lp7 ~]# 

After upgrading to the subscription-manager targeted for release on RHEL68...
[root@ibm-p8-05-lp7 ~]# rpm -q subscription-manager
subscription-manager-1.16.8-2.el6.ppc64
[root@ibm-p8-05-lp7 ~]# virt-what 
[root@ibm-p8-05-lp7 ~]# 
[root@ibm-p8-05-lp7 ~]# subscription-manager facts | grep virtvirt.host_type: Not Applicable
virt.is_guest: False
virt.uuid: Unknown          <======== NEWLY ADDED AND UNEXPECTED
[root@ibm-p8-05-lp7 ~]# 


Actual results:
 above

Expected results:
 virt.uuid should only be shown when virt.is_guest: True

Additional info:


[root@ibm-p8-05-lp7 ~]# subscription-manager facts --list | grep proc_cpuinfo
proc_cpuinfo.common.machine: CHRP IBM,8247-22L
proc_cpuinfo.common.model: IBM,8247-22L
proc_cpuinfo.common.platform: pSeries

NEEDINFO: In light of recent LPAR work, maybe this ppc64 system is indeed a guest and virt-what is actually failing to report it.
Comment 2 Adrian Likins 2016-02-15 16:43:58 EST
pr at https://github.com/candlepin/subscription-manager/pull/1386

There can be cases where virt-what doesn't know the system is a virt guest, but we can find a virt.uuid anyway (ppc lpar mainly). This was changed as part of that, but the old behavior in this case is just as valid, so changing it back.

(ie, if we don't find a virt.uuid, don't add a 'virt.uuid' fact at all. Interim
was setting it to 'Unknown')l
Comment 6 Rehana 2016-02-25 02:49:48 EST
Reproducing the failure :
------------------------

[root@ibm-p8-05-lp5 ~]# rpm -q subscription-manager
subscription-manager-1.16.8-2.el6.ppc64


[root@ibm-p8-05-lp5 ~]# virt-what 

[root@ibm-p8-05-lp5 ~]#  subscription-manager facts | grep virt
virt.host_type: Not Applicable
virt.is_guest: False
virt.uuid: Unknown

[root@ibm-p8-05-lp5 ~]# subscription-manager facts --list | grep proc_cpuinfo
proc_cpuinfo.common.machine: CHRP IBM,8247-22L
proc_cpuinfo.common.model: IBM,8247-22L
proc_cpuinfo.common.platform: pSeries

With the updated subscription-manager packages:
-----------------------------------------------
[root@ibm-p8-05-lp6 ~]# virt-what 

[root@ibm-p8-05-lp6 ~]# subscription-manager facts | grep virt
virt.host_type: Not Applicable
virt.is_guest: False

[root@ibm-p8-05-lp6 ~]# rpm -q subscription-manager
subscription-manager-1.16.8-3.el6.ppc64

[root@ibm-p8-05-lp6 ~]# subscription-manager facts --list | grep proc_cpuinfo
proc_cpuinfo.common.machine: CHRP IBM,8247-22L
proc_cpuinfo.common.model: IBM,8247-22L
proc_cpuinfo.common.platform: pSeries

Marking the bug as verified!!
Comment 8 errata-xmlrpc 2016-05-10 16:40:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.