Bug 1308737 - rebase cockpit-kubernetes to match other cockpit packages in Extras
rebase cockpit-kubernetes to match other cockpit packages in Extras
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Dodson
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 17:10 EST by Dominik Perpeet
Modified: 2016-02-23 09:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 09:08:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KubernetesNode (20.49 KB, image/png)
2016-02-19 01:44 EST, yapei
no flags Details

  None (edit)
Comment 12 yapei 2016-02-18 08:21:54 EST
Have re-deploy OSE env with cockpit installed, will continue to test
Comment 13 yapei 2016-02-18 21:03:34 EST
Hi,

Tested against our OSE environment 
openshift v3.1.1.903
kubernetes v1.2.0-origin
etcd 2.2.2+git

Checked openshift console at https://master:8443,features(from my view, Typology View,Pod Terminal, Pod logs...) integrated with cockpit works fine.

Do i need to check functionalities on cockpit-kubernetes UI at https://master:9090?
Comment 15 Scott Dodson 2016-02-18 22:08:38 EST
(In reply to yapei from comment #13)
> Hi,
> 
> Tested against our OSE environment 
> openshift v3.1.1.903
> kubernetes v1.2.0-origin
> etcd 2.2.2+git
> 
> Checked openshift console at https://master:8443,features(from my view,
> Typology View,Pod Terminal, Pod logs...) integrated with cockpit works fine.
> 
> Do i need to check functionalities on cockpit-kubernetes UI at
> https://master:9090?

Yes, once signing in please make sure that the Cluster tab works. If it's not working the main panel will be completely blank. I've actually verified this myself but we need QE to ack the bug.
Comment 16 yapei 2016-02-19 01:44:13 EST
Overview, Containers, Topology, Details, Images panel in "Cluster" tab could display well

But just one thing to confirm, will these contents in Overview, Containers, Topology, Details, Images panels change when I switch between projects? 

Also see some minor display issue about "Kubernetes Nodes" table
Comment 17 yapei 2016-02-19 01:44 EST
Created attachment 1128466 [details]
KubernetesNode
Comment 18 yapei 2016-02-19 02:19:34 EST
confirmed that Overview, Containers, Topology, Details, Images contents will change when I switch between project, some network problem before. This means Cluster tab and its panels works fine

only this minor display issue now.
Comment 19 yapei 2016-02-19 05:20:36 EST
If cockpit-kubernetes UI is not the testing scope of this bug, I will move to verified.
Comment 20 Scott Dodson 2016-02-19 09:24:26 EST
My opinion is that this bug's purpose is to restore functionality that's completely broken in its current state. We should mark this as VERIFIED and file a new bug against cockpit itself for the display issue.
Comment 21 Scott Dodson 2016-02-19 09:25:45 EST
Sorry, I was less clear than I should've been. I mean it's completely broken when using cockpit-0.93 and cockpit-kubernetes-0.77 therefore the purpose of this bug is to restore working cockpit-kubernetes functionality by upgrading it to 0.93.
Comment 22 yapei 2016-02-20 06:13:01 EST
I think I should understand it, move to verified, thanks a lot
Comment 24 errata-xmlrpc 2016-02-23 09:08:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0288

Note You need to log in before you can comment on or make changes to this bug.