Bug 1308746 - [RFE] PAPR Hash Page Table resizing (RHEV)
[RFE] PAPR Hash Page Table resizing (RHEV)
Status: CLOSED DUPLICATE of bug 1308744
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
4.0.0
ppc64le Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Scott Herold
Gil Klein
: FutureFeature
Depends On: 1305398 1308743
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 17:37 EST by Karen Noel
Modified: 2016-02-15 17:40 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1308743
Environment:
Last Closed: 2016-02-15 17:40:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karen Noel 2016-02-15 17:37:03 EST
RHEV should determine if the guest supports HPT resizing, then increase the default max size of memory.

+++ This bug was initially created as a clone of Bug #1308743 +++

In case libvirt requires changes to support HPT resizing. If no changes required, set this BZ to TestOnly.

+++ This bug was initially created as a clone of Bug #1305398 +++

Description of problem:

Allow the hash page table (HPT) of PAPR guests to be resized at runtime.

This is important for practical memory hotplug.  Without this the HPT needs to be sized for the guest's maximum possible memory - since RHEV wants to set that to 4T, this can result in a much bigger than necessary HPT which wastes host resources and can cause allocation failures.  With HV KVM the HPT is unswappable, contiguous host memory.

This BZ covers the qemu parts of this including TCG and PR KVM implementation of the necessary hypercalls, feature negotation with the guest and enabling the necessary KVM host pieces.

--- Additional comment from David Gibson on 2016-02-07 19:52:00 EST ---

An RFC has been posted upstream:

https://lists.gnu.org/archive/html/qemu-devel/2016-01/msg05852.html
Comment 1 Karen Noel 2016-02-15 17:40:31 EST

*** This bug has been marked as a duplicate of bug 1308744 ***

Note You need to log in before you can comment on or make changes to this bug.