This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1308786 - virt-who will start infinite loop with 900s(15m), even if the interval value is 3600s(60m)
virt-who will start infinite loop with 900s(15m), even if the interval value...
Status: CLOSED DUPLICATE of bug 1230041
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.8
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Eko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 00:19 EST by Eko
Modified: 2016-11-30 19:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 00:34:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eko 2016-02-16 00:19:38 EST
Description of problem:
virt-who will check the host/guests changes with 900s loop, even if the interval value is 3600s

Version-Release number of selected component (if applicable):
RHEL-6.8-20160212.2 + ESX + Satellite
virt-who-0.16-3.el6.noarch
subscription-manager-1.16.8-2.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. config VIRTWHO_INTERVAL to 3600, such as:
VIRTWHO_INTERVAL=3600
VIRTWHO_ESX=1
VIRTWHO_ESX_OWNER=ACME_Corporation
VIRTWHO_ESX_ENV=Library
VIRTWHO_ESX_SERVER=10.73.2.95
VIRTWHO_ESX_USERNAME=Administrator@vsphere.local
VIRTWHO_ESX_PASSWORD=Welcome1!

2. restart virt-who service
# /etc/init.d/virt-who restart

3. check rhsm.log
# tail -f /var/log/rhsm/rhsm.log
2016-02-16 11:46:34,541 [virtwho.init INFO] MainProcess(5322):MainThread @virtwho.py:parseOptions:630 - Using reporter_id='hp-z220-09.qe.lab.eng.nay.redhat.com'
2016-02-16 11:46:34,543 [virtwho.init INFO] MainProcess(5322):MainThread @virtwho.py:main:721 - Using configuration "env/cmdline" ("esx" mode)
2016-02-16 11:46:34,544 [virtwho.main DEBUG] MainProcess(5322):MainThread @virtwho.py:run:229 - Starting infinite loop with 3600 seconds interval
2016-02-16 11:46:34,646 [virtwho.env_cmdline DEBUG] Esx-1(5329):MainThread @virt.py:run:358 - Virt backend 'env/cmdline' started
2016-02-16 11:46:34,647 [virtwho.env_cmdline DEBUG] Esx-1(5329):MainThread @esx.py:_prepare:55 - Log into ESX
2016-02-16 11:46:34,967 [virtwho.env_cmdline DEBUG] Esx-1(5329):MainThread @esx.py:_prepare:58 - Creating ESX event filter
2016-02-16 11:46:35,115 [virtwho.env_cmdline DEBUG] Esx-1(5329):MainThread @virt.py:enqueue:351 - Report gathered, putting to queue for sending
2016-02-16 11:46:35,115 [virtwho.env_cmdline DEBUG] Esx-1(5329):MainThread @esx.py:_run:150 - Waiting for ESX changes
2016-02-16 11:46:35,130 [virtwho.main DEBUG] MainProcess(5322):MainThread @subscriptionmanager.py:_connect:121 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2016-02-16 11:46:35,357 [virtwho.main DEBUG] MainProcess(5322):MainThread @subscriptionmanager.py:hypervisorCheckIn:162 - Checking if server has capability 'hypervisor_async'
2016-02-16 11:46:35,545 [virtwho.main DEBUG] MainProcess(5322):MainThread @subscriptionmanager.py:hypervisorCheckIn:174 - Server does not have 'hypervisors_async' capability
2016-02-16 11:46:35,546 [virtwho.main INFO] MainProcess(5322):MainThread @subscriptionmanager.py:hypervisorCheckIn:185 - Sending update in hosts-to-guests mapping for config "env/cmdline": 1 hypervisors and 1 guests found
2016-02-16 11:46:35,547 [virtwho.main DEBUG] MainProcess(5322):MainThread @subscriptionmanager.py:hypervisorCheckIn:186 - Host-to-guest mapping: {
    "3e504d56-3982-037b-f3e6-669289892fa1": [
        {
            "guestId": "42064eca-44da-56fa-1946-9b6f6cb67dab", 
            "state": 5, 
            "attributes": {
                "active": 0, 
                "hypervisorVersion": "6.0.0", 
                "virtWhoType": "esx", 
                "hypervisorType": "VMware ESXi"
            }
        }
    ]
}
2016-02-16 11:46:35,812 [virtwho.main DEBUG] MainProcess(5322):MainThread @virtwho.py:send_current_report:159 - Report for config "env/cmdline" sent

=============== loop each 15 minutes, not 60 minutes =================
2016-02-16 12:01:35,217 [virtwho.env_cmdline DEBUG] Esx-1(5329):MainThread @esx.py:_run:150 - Waiting for ESX changes
2016-02-16 12:16:35,270 [virtwho.env_cmdline DEBUG] Esx-1(5329):MainThread @esx.py:_run:150 - Waiting for ESX changes
2016-02-16 12:31:35,350 [virtwho.env_cmdline DEBUG] Esx-1(5329):MainThread @esx.py:_run:150 - Waiting for ESX changes


Actual results:
the interval value is 3600s, but the really loop time is 900s

Expected results:
virt-who should check the host/guests changes each 3600s

Additional info:
Comment 2 Eko 2016-02-16 00:34:27 EST

*** This bug has been marked as a duplicate of bug 1230041 ***

Note You need to log in before you can comment on or make changes to this bug.