Bug 1308802 - Adding hosts to cluster, doesn't perform network time sync with NTP
Adding hosts to cluster, doesn't perform network time sync with NTP
Status: CLOSED WONTFIX
Product: vdsm
Classification: oVirt
Component: Services (Show other bugs)
---
x86_64 Linux
unspecified Severity high (vote)
: ---
: ---
Assigned To: Yaniv Bronhaim
Aharon Canan
:
Depends On:
Blocks: Gluster-HC-1
  Show dependency treegraph
 
Reported: 2016-02-16 01:55 EST by SATHEESARAN
Modified: 2017-05-11 05:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEV-RHGS Hyperconvergence
Last Closed: 2016-02-16 08:08:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sasundar: planning_ack?
sasundar: devel_ack?
sasundar: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2016-02-16 01:55:20 EST
Description of problem:
-----------------------
I have created a hosted-engine with a single node and added 2 more nodes to the hosted-engine cluster.

I observed that the all the hosts are not network time synced with the help of NTP

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHEV 3.6 beta3

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Create a hosted-engine setup on a host ( RHEL 7.2 )
2. Add 2 more nodes to the cluster
3. Check for the localtime on all the nodes using 'date' command

Actual results:
---------------
All the nodes in the hosted-engine cluster is not network time synced

Expected results:
-----------------
hosted-engine deployment should take care of network time sync the nodes added to the cluster

Additional info:
----------------
For Hyperconvergence deployment, gluster servers needs to be Network Time Synced using NTP protocol.
https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html-single/Installation_Guide/index.html#Network_Time_Protocol_Setup

The date as found on the three hosts added to the cluster :

host1
------
[root ~]# date
Tue Feb 16 11:47:29 IST 2016

host2
-----
[root@ ~]# date
Tue Feb 16 11:47:28 IST 2016

host3
------
[root@ ~]# date
Tue Feb 16 01:17:28 EST 2016
Comment 1 Sandro Bonazzola 2016-02-16 03:04:29 EST
Neither ovirt-hosted-engine-setup nor ovirt-host-deploy handles NTP daemon.
Looks like VDSM is the only one handling it.
Moving to VDSM.
Comment 2 Sandro Bonazzola 2016-02-16 03:05:21 EST
Not specific to hosted engine.
Comment 3 Oved Ourfali 2016-02-16 08:08:54 EST
We indeed don't handle NTP in the product, and have no plans to do that.

Note You need to log in before you can comment on or make changes to this bug.