Bug 1308819 - fedmsg-notify-config does not run after installation of fedmsg-notify
fedmsg-notify-config does not run after installation of fedmsg-notify
Status: CLOSED DUPLICATE of bug 1246859
Product: Fedora
Classification: Fedora
Component: fedmsg-notify (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Infrastructure SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 03:23 EST by clime
Modified: 2016-09-25 15:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-25 15:04:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description clime 2016-02-16 03:23:59 EST
Description of problem:

clime@coprbox ~ $ sudo dnf install fedmsg-notify
Fedora 23 - x86_64 - Test Updates                   13 MB/s | 4.0 MB     00:00    
Copr repo for copr-prune-repo owned by clime       1.8 kB/s | 1.4 kB     00:00    
Fedora 23 - x86_64 - Updates                        24 MB/s |  18 MB     00:00    
Last metadata expiration check performed 0:00:04 ago on Tue Feb 16 08:45:38 2016.
Dependencies resolved.
===================================================================================
 Package                                Arch   Version       Repository       Size
===================================================================================
Installing:
 fedmsg-notify                          noarch 0.5.5-3.fc23  fedora           47 k
 python2-fedmsg-meta-fedora-infrastructure
                                        noarch 0.15.8-1.fc23 updates-testing 347 k

Transaction Summary
===================================================================================
Install  2 Packages

Total download size: 394 k
Installed size: 2.2 M
Is this ok [y/N]: y
Downloading Packages:
[MIRROR] python2-fedmsg-meta-fedora-infrastructure-0.15.8-1.fc23.noarch.rpm: Status code: 404 for http://download.eng.brq.redhat.com/pub/fedora/linux/updates/testing/23/x86_64/p/python2-fedmsg-meta-fedora-infrastructure-0.15.8-1.fc23.noarch.rpm
(1/2): fedmsg-notify-0.5.5-3.fc23.noarch.rpm       1.0 MB/s |  47 kB     00:00    
(2/2): python2-fedmsg-meta-fedora-infrastructure-0 797 kB/s | 347 kB     00:00    
-----------------------------------------------------------------------------------
Total                                              142 kB/s | 394 kB     00:02     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : python2-fedmsg-meta-fedora-infrastructure-0.15.8-1.fc23.noar   1/2 
  Installing  : fedmsg-notify-0.5.5-3.fc23.noarch                              2/2 
  Verifying   : fedmsg-notify-0.5.5-3.fc23.noarch                              1/2 
  Verifying   : python2-fedmsg-meta-fedora-infrastructure-0.15.8-1.fc23.noar   2/2 

Installed:
  fedmsg-notify.noarch 0.5.5-3.fc23                                                
  python2-fedmsg-meta-fedora-infrastructure.noarch 0.15.8-1.fc23                   

Complete!
clime@coprbox ~ $ fedmsg-notify-config
Traceback (most recent call last):
  File "/usr/bin/fedmsg-notify-config", line 9, in <module>
    load_entry_point('fedmsg-notify==0.5.5', 'console_scripts', 'fedmsg-notify-config')()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 558, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2682, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2355, in load
    return self.resolve()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2361, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python2.7/site-packages/fedmsg_notify/gui.py", line 21, in <module>
    import dbus
ImportError: No module named dbus
clime@coprbox ~ $ sudo dnf install dbus-python
Last metadata expiration check performed 0:04:35 ago on Tue Feb 16 08:45:38 2016.
Dependencies resolved.
===================================================================================
 Package             Arch           Version                  Repository       Size
===================================================================================
Installing:
 dbus-python         x86_64         1.2.0-12.fc23            updates         129 k

Transaction Summary
===================================================================================
Install  1 Package

Total download size: 129 k
Installed size: 479 k
Is this ok [y/N]: y
Downloading Packages:
dbus-python-1.2.0-12.fc23.x86_64.rpm               2.5 MB/s | 129 kB     00:00
-----------------------------------------------------------------------------------
Total                                              128 kB/s | 129 kB     00:01
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : dbus-python-1.2.0-12.fc23.x86_64                               1/1
  Verifying   : dbus-python-1.2.0-12.fc23.x86_64                               1/1

Installed:
  dbus-python.x86_64 1.2.0-12.fc23

Complete!
clime@coprbox ~ $ fedmsg-notify-config
/usr/lib/python2.7/site-packages/fedmsg_notify/gui.py:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, Gio
Traceback (most recent call last):
  File "/usr/bin/fedmsg-notify-config", line 9, in <module>
    load_entry_point('fedmsg-notify==0.5.5', 'console_scripts', 'fedmsg-notify-config')()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 558, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2682, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2355, in load
    return self.resolve()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2361, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python2.7/site-packages/fedmsg_notify/gui.py", line 27, in <module>
    from .filters import filters, get_enabled_filters
  File "/usr/lib/python2.7/site-packages/fedmsg_notify/filters.py", line 24, in <module>
    from .distro_specific import (get_installed_packages,
ImportError: cannot import name get_reported_bugs



Version-Release number of selected component (if applicable):
Version     : 0.5.5
Release     : 3.fc23



Expected results:
I would expect that fedmsg-notify-config will run without problems after installation of fedmsg-notify. I proceeded according to this article: https://fedoramagazine.org/how-fedora-monitors-upstream-releases/
Comment 2 Kevin Fenzi 2016-09-25 15:04:25 EDT

*** This bug has been marked as a duplicate of bug 1246859 ***

Note You need to log in before you can comment on or make changes to this bug.