Bug 1308825 - [FutureFeature] RHGS SMB support for Windows "previous versions" functionality
[FutureFeature] RHGS SMB support for Windows "previous versions" functionality
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: rjoseph
Vivek Das
: FutureFeature, ZStream
: 1290049 (view as bug list)
Depends On: 1329718 1329716
Blocks: 1311386
  Show dependency treegraph
 
Reported: 2016-02-16 03:52 EST by Marcel Hergaarden
Modified: 2016-06-23 01:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:37:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Hergaarden 2016-02-16 03:52:17 EST
Description of problem:

Red Hat Gluster Storage is getting interest for Windows file service.
Within Windows filesystems a capability exists for "Previous Versions"
This feature is often asked for in RHGS RFI/RFP trajects.
Currently we don't support this, however it seems to be a realistic possibility from a SAMBA perspective.


Version-Release number of selected component (if applicable):
RHGS 3.1 (and higher)


How reproducible:
Create a SMB share, use a MS Windows client to connect to the RHGS SMB share
Try to access previous versions in Windows. This is not available.


Steps to Reproduce:
1.Create a RHGS volume and export by SMB
2.Access the volume with MS Windows
3.Try to access previous versions in Windows

Actual results:
Not possible

Expected results:
Wannahave

Additional info:
[1] https://www.samba.org/samba/docs/man/manpages/vfs_shadow_copy2.8.html
[2] http://windows.microsoft.com/en-us/windows/previous-versions-files-faq#1TC=windows-7

This feature is frequently asked for by prospect customers.
Comment 3 Michael Adam 2016-04-13 05:38:05 EDT
*** Bug 1290049 has been marked as a duplicate of this bug. ***
Comment 4 Michael Adam 2016-04-13 05:39:46 EDT
The basic functionality is already present in the existing builds.
A patch to enhance the usability of snapshots via the shadow_copy2
module is currently under review.
Comment 5 rjoseph 2016-04-25 06:11:31 EDT
The feature patch is merged. With this the basic functionality of shadow-copy should be working. Therefore moving this bug to ON_QA. Any bugs in the feature can be tracked separately.
Comment 6 Vivek Das 2016-05-30 11:11:41 EDT
Basic functionality works fine.
Comment 8 errata-xmlrpc 2016-06-23 01:37:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1248

Note You need to log in before you can comment on or make changes to this bug.