Bug 1308839 - [vmfex-hook] - Failed to run VM with vdsm-hook-vmfex-dev-4.17.20
[vmfex-hook] - Failed to run VM with vdsm-hook-vmfex-dev-4.17.20
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.20
x86_64 Linux
high Severity high (vote)
: ovirt-3.6.4
: 4.17.23
Assigned To: Dan Kenigsberg
Michael Burman
: Regression
Depends On:
Blocks: 1305338
  Show dependency treegraph
 
Reported: 2016-02-16 04:23 EST by Michael Burman
Modified: 2016-04-05 09:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: v4.17.23.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-05 09:53:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
danken: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
vdsm log (124.30 KB, application/x-gzip)
2016-02-16 04:23 EST, Michael Burman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53571 master MERGED vmfex hook: remove filter from directly-attached vnics 2016-02-17 04:17 EST
oVirt gerrit 53632 ovirt-3.6 MERGED vmfex hook: remove filter from directly-attached vnics 2016-02-23 03:45 EST
oVirt gerrit 54389 ovirt-3.6.3 MERGED vmfex hook: remove filter from directly-attached vnics 2016-03-08 06:08 EST

  None (edit)
Description Michael Burman 2016-02-16 04:23:46 EST
Created attachment 1127543 [details]
vdsm log

Description of problem:
[vmfex-hook] - Failed to run VM with vdsm-hook-vmfex-dev-4.17.20

Thread-115::ERROR::2016-02-16 10:40:20,087::vm::759::virt.vm::(_startUnderlyingVm) vmId=`404f96db-b224-4163-a21e-eeb8eb084d7b`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/vm.py", line 703, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/virt/vm.py", line 1941, in _run
    self._connection.createXML(domxml, flags),
  File "/usr/lib/python2.7/site-packages/vdsm/libvirtconnection.py", line 124, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/vdsm/utils.py", line 1313, in wrapper
    return func(inst, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3611, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: unsupported configuration: filterref is not supported for network interfaces of type direct
Thread-115::INFO::2016-02-16 10:40:20,088::vm::1330::virt.vm::(setDownStatus) vmId=`404f96db-b224-4163-a21e-eeb8eb084d7b`::Changed state to Down: unsupported configuration: filterref is not supported for network interfaces of type direct (code=1)

Version-Release number of selected component (if applicable):
vdsm-hook-vmfex-dev-4.17.20-0.el7ev.noarch
vdsm-4.17.20-0.el7ev.noarch

How reproducible:
100

Steps to Reproduce:
1. Try to run VM using vmfex vNIC profile on a UCS server 

Actual results:
Failed to run VM with error:
"VM v4 is down with error. Exit message: unsupported configuration: filterref is not supported for network interfaces of type direct."

Expected results:
Should work and run as expected(as working on 3.5.8)
Comment 1 Dan Kenigsberg 2016-02-16 05:13:04 EST
libvirt-1.2.17-13.el7_2.3.x86_64
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-16 05:13:07 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 3 Red Hat Bugzilla Rules Engine 2016-03-06 06:59:20 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 4 Dan Kenigsberg 2016-03-17 06:33:19 EDT
This patch has actually made it into vdsm-4.17.23.1, which is testable now.
Comment 5 Michael Burman 2016-03-17 07:03:23 EDT
Verified on - 3.6.4-0.1.el6 and vdsm-4.17.23.1-0.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.