Bug 130884 - Snapshots not created if using up2date
Snapshots not created if using up2date
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Warner
Max Spevack
:
Depends On:
Blocks: 135141
  Show dependency treegraph
 
Reported: 2004-08-25 11:42 EDT by Nick Strugnell
Modified: 2007-07-31 10:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 07:31:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Strugnell 2004-08-25 11:42:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040303

Description of problem:
We have a system registered to a 3.4 satellite via a RHN proxy.

This machine was inadvertantly updated using 'up2date -u' on the
commandline.

We wanted to rollback this machine, but the only packages profile
change snapshot that was saved was a kernel update, even though about
30 packages were updated with this up2date.

Version-Release number of selected component (if applicable):
up2date-4.2.33-1

How reproducible:
Didn't try

Steps to Reproduce:
1. up2date -u
2. Go to snapshots->rollback on RHN satellite
3. Check snapshot profiles
    

Actual Results:  could not find a snapshot that matched the package
changes in the update

Expected Results:  a snapshot corresponding to the up2date should exist

Additional info:

Eventually saved the system by doing a profile sync to an identical
server that had not been updated.
Comment 1 Nick Strugnell 2004-09-24 06:18:14 EDT
Can someone pick this up? British Airways are waiting on this.
Comment 2 Mihai Ibanescu 2004-10-07 00:37:36 EDT
I believe this is related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125790
Comment 3 Mihai Ibanescu 2004-10-08 15:39:19 EDT
Todd, can you help with reproducing this?
Comment 4 Todd Warner 2004-10-25 21:57:41 EDT
Works fine with
up2date-2.9.14-1.2.1AS
up2date-4.2.14-1

Against RHN Sat 3.4.  The RHEL 3 box (up2date-4.2.14) was going
through an RHN Proxy 3.2 even.

I.e., works for me.
Comment 5 Todd Warner 2004-11-21 22:43:50 EST
Cliff, you have anything to comment about this?
Comment 6 Max Spevack 2004-12-08 14:40:27 EST
Comments?  I would like to close this if it's old/resolved
Comment 8 Clifford Perry 2004-12-16 12:04:40 EST
Testing with:
- RHN Satellite 3.4 with schema 3.4-48 & rhns-3.4.0-53
- RHN Proxy 3.2.2 - rhns-proxy-3.2.2-28
- ES 3 Update 3 with up2date-4.2.38-1

I had the client registered to the satellite, going through the proxy
with a provisioning entitlement. 

Ran up2date -uf and downloaded 
kernel                                  2.4.21         20.0.1.EL     
   i686
kernel-source                           2.4.21         20.0.1.EL     
   i386
libxml2                                 2.5.10         7             
   i386
libxml2-python                          2.5.10         7             
   i386
 
Within the Satellite Web UI for this system I went to snapshots ->
Package profile -> packages and noted that it had listed :

kernel  	 2.4.21-20.0.1.EL  	 2.4.21-4.EL  	 Current profile newer
kernel-source 	2.4.21-20.0.1.EL 	  	Current profile only
libxml2 	2.5.10-7 	  	Current profile only
libxml2-python 	2.5.10-7 	  	Current profile only

So, as such, everything from my own test worked correctly and as
expected. 

Cliff. 
Comment 10 Todd Warner 2004-12-17 07:31:50 EST
closing as CURRENTRELEASE then.

Note You need to log in before you can comment on or make changes to this bug.