Bug 130886 - Profile sync fails via proxy
Summary: Profile sync fails via proxy
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Vlady Zlatkin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 151684
TreeView+ depends on / blocked
 
Reported: 2004-08-25 15:50 UTC by Nick Strugnell
Modified: 2007-07-31 14:32 UTC (History)
3 users (show)

Fixed In Version: rhn372
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 21:49:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn_check -vvv run when registered against a proxy (12.61 KB, text/plain)
2004-10-20 23:09 UTC, Vlady Zlatkin
no flags Details
rhn_check -vvv run when registered against a satellite (worked) (11.29 KB, text/plain)
2004-10-20 23:14 UTC, Vlady Zlatkin
no flags Details
what actions were performed, same for proxy and sat (7.78 KB, text/plain)
2004-10-20 23:15 UTC, Vlady Zlatkin
no flags Details

Description Nick Strugnell 2004-08-25 15:50:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040303

Description of problem:
Tried to do a profile sync on a system connected to the satellite via
an RHN proxy. The sync required many packages to be downgraded.

This failed with a 'package not found' error on the first packages
that needed downgrading, presumably because it did not exist on the proxy.

Version-Release number of selected component (if applicable):
satellite 3.4, proxy 3.2

How reproducible:
Didn't try

Steps to Reproduce:
1.Configure a profile sync for a server connected via a proxy.
2. Run rhn_check on the server.
3.
    

Actual Results:  Failure - unfortunately do not have log results, but
the packages were not available on the proxy - there was a message
saying 'Mapping does not exist' or similar.

Expected Results:  profile sync should have worked.

Additional info:

Workaround: temporarily point the server directly at the satellite
rather than at the proxy (/etc/sysconfig/rhn/up2date)

Comment 1 Nick Strugnell 2004-09-24 10:17:01 UTC
Can someone pick this up? British Airways are waiting on this.

Comment 2 Mihai Ibanescu 2004-10-07 04:35:59 UTC
Todd, can you please have a look?

Comment 3 Todd Warner 2004-10-07 06:43:32 UTC
Needs to be an issue tracker. Sorry I this did not crop up on my radar
sooner.

Comment 4 Vlady Zlatkin 2004-10-20 23:07:39 UTC
verified,

steps:

created proxy 3.2 on rhel2.1
used sat on farm03
kickstarted another machine to rhel3u4, registered to proxy
did a package sync profile through web ui
rhn_check -vvv gave a file not found

worked when re-registered through the satellite and synced to the same
profile

Comment 5 Vlady Zlatkin 2004-10-20 23:09:21 UTC
Created attachment 105561 [details]
rhn_check -vvv run when registered against a proxy

Comment 6 Vlady Zlatkin 2004-10-20 23:14:01 UTC
Created attachment 105562 [details]
rhn_check -vvv run when registered against a satellite (worked)

Comment 7 Vlady Zlatkin 2004-10-20 23:15:38 UTC
Created attachment 105564 [details]
what actions were performed, same for proxy and sat

Comment 8 Vlady Zlatkin 2004-10-21 14:29:36 UTC
upon further investigation, i found that in both cases the profile
sync fails, if the machine is connected directly to a satellite the
error message is only displayed on the satellite's webui and not
during rhn_check


Comment 9 Todd Warner 2004-11-05 08:35:49 UTC
What precisely is failing though?

Comment 11 David Lawrence 2005-09-25 23:43:07 UTC
Attempting change to NEEDINFO_QA

Comment 12 David Lawrence 2006-04-12 18:38:33 UTC
The status NEEDINFO_QA has been deprecated in favor of NEEDINFO. Moving bugs to
NEEDINFO.

Comment 13 Mike McCune 2006-08-01 16:34:03 UTC
reassigning to bretm


Note You need to log in before you can comment on or make changes to this bug.