Bug 1308860 - CLI Error not raised while setting default value when 'Override' set to False for parameter.
CLI Error not raised while setting default value when 'Override' set to False...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: orabin
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1278718
  Show dependency treegraph
 
Reported: 2016-02-16 04:58 EST by Jitendra Yejare
Modified: 2016-07-27 07:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:43:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot Attached (134.69 KB, image/png)
2016-02-16 04:58 EST, Jitendra Yejare
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13727 None None None 2016-04-22 12:40 EDT

  None (edit)
Description Jitendra Yejare 2016-02-16 04:58:59 EST
Created attachment 1127547 [details]
Screenshot Attached

Description of problem:
User is able to set the default value for parameter even if the 'override' flag is not set for the parameter, which is not expected.
Note: This issue is only observed in CLI and not in UI.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201601251557git59dc77b.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Attempt to set default value for parameter which override flag is set to False.

Actual results:
Default Value successfully updated and no error raised.

Expected results:
1. Error/Info should be raised to set the 'override' flag to True first.
2. Default Value should not be updated.

Additional info:
Comment 3 Jitendra Yejare 2016-02-16 06:16:12 EST
Same scenario is reproducible from API as well in same build.
Comment 4 Bryan Kearney 2016-02-16 08:08:21 EST
Upstream bug component is Provisioning
Comment 5 Bryan Kearney 2016-02-17 04:08:19 EST
Upstream bug assigned to orabin@redhat.com
Comment 6 Bryan Kearney 2016-02-17 04:08:20 EST
Upstream bug assigned to orabin@redhat.com
Comment 7 Bryan Kearney 2016-03-28 12:08:41 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13727 has been closed
-------------
Ori Rabin
Applied in changeset commit:2a08e8c1deac40c26932dc80ca53e89bfe9e493b.
Comment 8 Mike McCune 2016-03-28 19:15:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 Jitendra Yejare 2016-05-19 09:01:19 EDT
Verified !
@Sat 6.2 Snap 11

Proof:

root@qeblade36 ~]# hammer sc-param update --id 322 --default-value [78]
Could not update the parameter:
  Validation failed: Override must be true to edit the parameter

So moving this to verified.
Comment 10 Bryan Kearney 2016-07-27 07:43:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.