Bug 1308862 - iostat -N doesn't show the full device name if it's longer than 72 characters
iostat -N doesn't show the full device name if it's longer than 72 characters
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sysstat (Show other bugs)
6.8
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Peter Schiffer
Branislav Náter
Petr Bokoc
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 05:15 EST by Alexis Solanas
Modified: 2016-05-10 16:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
"iostat" can now print device names longer than 72 characters Previously, device names longer than 72 characters were being truncated in "iostat" output because the device name field was too short. The allocated space for device names has been increased, and "iostat" can now print significantly longer device names in the output.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:32:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexis Solanas 2016-02-16 05:15:54 EST
Description of problem:

'iostat -N' truncates the name of the device to 72 characters.
Need to extend it to 128 characters to match BZ#1267972 

Version-Release number of selected component (if applicable):
sysstat-9.0.4-27.el6


How reproducible:

Always


Steps to Reproduce:

  1. Create a device name with more than 72 characters
  2. run "iostat -N"
  3. Check the device name against the output of "dmsetup info -c"

Actual results:

  Device name for the device is truncated to 72 characters

Expected results:

  Full device name for the device is shown

Additional info:

  Customer requested the same fix of BZ#1267972 to be applied to sysstat in RHEL6
Comment 9 errata-xmlrpc 2016-05-10 16:32:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0790.html

Note You need to log in before you can comment on or make changes to this bug.