Bug 1308867 - Discovered hosts are not removed from the table in steps 2B/2C of RHEV deployment
Discovered hosts are not removed from the table in steps 2B/2C of RHEV deploy...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: Erik Nelson
Tasos Papaioannou
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 05:27 EST by Antonin Pagac
Modified: 2016-09-13 12:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
step 2B of RHEV deployment (73.07 KB, image/png)
2016-02-16 05:27 EST, Antonin Pagac
no flags Details

  None (edit)
Description Antonin Pagac 2016-02-16 05:27:35 EST
Created attachment 1127554 [details]
step 2B of RHEV deployment

Description of problem:
I started an all-in-one deployment and got up to step 2B of RHEV deployment. I saw I can choose from two hosts, but I decided to re-discover them, just to be on the safe side. I deleted the hosts from satellite via "Hosts -> Discovered hosts" but when I looked at the deployment and clicked on "Refresh data", the hosts were still displayed in the table. I then restarted the bare metal machines and they got discovered by Satellite again, so now I can see two hosts in "Hosts -> Discovered hosts", however there are four hosts in step 2B of the RHEV deployment, two identical lines for each host, see screenshot. 

Version-Release number of selected component (if applicable):
TP2 RC9
RHCI-6.0-RHEL-7-20160208.1-RHCI-x86_64-dvd1.iso
RHCIOOO-7-RHEL-7-20160127.0-RHCIOOO-x86_64-dvd1.iso

How reproducible:
Always

Steps to Reproduce:
1. Start a deployment of RHEV with previously discovered hosts
2. Get to step 2B
3. Delete the discovered hosts in Satellite "Hosts -> Discovered hosts"
4. Hosts are successfully deleted from Satellite but still visible in the table in step 2B of RHEV deployment

Actual results:
Hosts deleted from Satellite but still visible in the table in step 2B of RHEV deployment

Expected results:
Hosts deleted from Satellite shouldn't be visible in the table in step 2B

Additional info:
Comment 1 Erik Nelson 2016-07-13 14:18:44 EDT
This was fixed during the course of development. I tested:

- 2 discovered hosts
- Navigated to the engine page, deleted hosts from Satellite, refreshed hosts in the fusor_ui and they disappeared as expected
- Restarted hosts so they would be rediscovered
- Refreshed the table in fusor_ui and both hosts showed back up as expected

Did the same for hypervisors, worked as expected.
Comment 6 Tasos Papaioannou 2016-07-21 16:45:55 EDT
Verified on QCI-1.2-RHEL-7-20160718.t.0.
Comment 8 errata-xmlrpc 2016-09-13 12:26:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.