Bug 1308888 - WIFI: ATH driver permanently resetting connection
WIFI: ATH driver permanently resetting connection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 06:14 EST by Ali Akcaagac
Modified: 2016-02-26 14:31 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 14:31:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journal.log (474.02 KB, text/x-vhdl)
2016-02-16 06:14 EST, Ali Akcaagac
no flags Details
jounral2.log (883.02 KB, text/x-vhdl)
2016-02-18 05:46 EST, Ali Akcaagac
no flags Details

  None (edit)
Description Ali Akcaagac 2016-02-16 06:14:46 EST
Created attachment 1127569 [details]
journal.log

Pulled in some updates last night, which includes a new kernel and linux-firmware. Dunno exactly which one causes this but since then I've been having permanent (and I mean permanent) WIFI resets.

Please find attached a journald.log file where you can count the number of resets within the last 1-2 hours.

-bash-4.3$ rpm -qa | grep -i "kernel"
kernel-core-4.3.5-200.fc22.i686
kernel-4.3.5-200.fc22.i686
kernel-modules-4.3.5-200.fc22.i686

-bash-4.3$ rpm -qa | grep -i "linux-firmware"
linux-firmware-20160204-61.git91d5dd13.fc22.noarch

Note: The line went offline 2 times during my writing here. I urge here because I depend on a working WIFI connection for work.
Comment 1 Ali Akcaagac 2016-02-18 04:36:37 EST
Ok this looks like it was caused by the recent glibc changes that might have affected my WLAN by causing infinite disconnects and reconnects within a short amount of time. Happened again early this morning when I turned the computer on. Then a new glibc update came by and after reset things have "stabilized". Keeping an eye on this and reporting back.
Comment 2 Florian Weimer 2016-02-18 05:18:16 EST
Sorry, I do not see how this is glibc-related.  If you rebooted the system and the symptoms disappeared, that's likely due to the reboot and not the glibc update.
Comment 3 Ali Akcaagac 2016-02-18 05:43:42 EST
The reset happened after I pulled in the glibc updates.

This morning, yesterday and the day before I kept getting resets over and over again. Within 60 seconds close to 60 connects/disconnects.

Now That I dont really know where in the chain to look, I therefore review the latest updated that might have caused this issue.

Changes and Updates happened:
- New Kernel package
- New Firmware package
- New Systemd package
- New Glibc updates that was altering code for DNS resolves and Co
  (at least from a quick look at the Fedora Git tree)

The net runs using NetworkManager under XFCE4

1) Hitronhub Modem reset
2) WRT-Router reset

Same issues with this system here. Another notebook connected to the same network (still running Fedora 20) has no issues. Same for Handhelds connected to the same network as well as network TV. This excludes the Hitronhub Modem and the WRT-Router from being defective.

So what else could be the cause ?

The notebook I am using has an external Atheros AR9271 WLAN adapter applied, which ran stable without even thinking about receiving a disconnect. I even have an aplified antenna attached to it (which can grab networks from all neighbourhood around us if needed).

So basicly it can be anything from the chain: Kernel → NetworkManager.

Kernel, ATH driver, Linux-Firmware, Glibc, Systemd, NetworkManager

The firmware is already excluded because I downgraded it.

So playing with parts of glibc (and rushing out updates), that cause other components to go nuts on this stable system might (and might not) be an issue. The changes may trigger parts of this chain to issue disconnects for whatever reasons.

Just noting this. You find attached a journald.log from the past 1-2 days. And I am willing to attach a new one that gave me plenty of disconnects in less than a minute - not knowing why.
Comment 4 Ali Akcaagac 2016-02-18 05:46 EST
Created attachment 1128185 [details]
jounral2.log

Fee free to count the disconnects/reconnects within 1-2 minutes on your own. Never seen that many NetworkManager entries in a log.
Comment 5 Florian Weimer 2016-02-18 05:54:10 EST
The glibc updates were released after your issues started, so they cannot be the cause here.  It could be a kernel regression, so reassigning to the kernel (although I have trouble identifying the actual error message in the log—but there are some messages suggesting hangs in the ath driver/hardware).
Comment 6 Ali Akcaagac 2016-02-26 14:31:41 EST
Reporting back.

No kernel issue, no glibc issue. After all it was loose connection. The USB was plugged in correctly but somehow issued this loose connection. I disconnected everything, cleaned the contacts and connectors and re-applied everything. No issues since then. Sorry for the trouble! But better I let you know rather than having someone else dig in the dark for possible bugs.

Note You need to log in before you can comment on or make changes to this bug.