Bug 1308889 - OSP director misconfigures Glance's RBD store parameters with external Ceph environment file
OSP director misconfigures Glance's RBD store parameters with external Ceph e...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
x86_64 Linux
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Giulio Fidente
Yogev Rabl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 06:15 EST by Yogev Rabl
Modified: 2016-04-07 17:47 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.14-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:47:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 280623 None None None 2016-02-16 06:47 EST
OpenStack gerrit 296433 None None None 2016-03-23 09:27 EDT

  None (edit)
Description Yogev Rabl 2016-02-16 06:15:38 EST
Description of problem:
A deployment of OSP with external Ceph cluster ended without errors. The deployment used puppet-ceph-external.yaml environment file:

resource_registry:
  OS::TripleO::CephClusterConfig::SoftwareConfig: ../puppet/extraconfig/ceph/ceph-external-config.yaml

parameter_defaults:
  # NOTE: These example parameters are required when using Ceph External
  CephClusterFSID: '<Cluster UID>'
  CephClientKey: '<yrabl-cinder UID>'
  CephExternalMonHost: '<monitor IP Address>'

  NovaEnableRbdBackend: true
  CinderEnableRbdBackend: true
  GlanceBackend: rbd

  NovaRbdPoolName: 'yrabl-nova'
  CinderRbdPoolName: 'yrabl-cinder'
  GlanceRbdPoolName: 'yrabl-glance'
  CephClientUserName: 'yrabl-cinder'

  # finally we disable the Cinder LVM backend
  CinderEnableIscsiBackend: false

After the deployment, the Glance configuration file shows the following store settings:
stores=glance.store.http.Store,glance.store.rbd.Store
default_store=rbd
rbd_store_chunk_size=8
rbd_store_pool=yrabl-cinder
rbd_store_user=openstack
rbd_store_ceph_conf=/etc/ceph/ceph.conf
rados_connect_timeout=0


Version-Release number of selected component (if applicable):
python-tripleoclient-0.1.1-2.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch
openstack-tripleo-heat-templates-kilo-0.8.7-12.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-2.el7ost.noarch
openstack-tripleo-heat-templates-0.8.7-12.el7ost.noarch
openstack-tripleo-0.0.7-1.el7ost.noarch
openstack-tripleo-common-0.1.1-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP with OSPD with the following command
# openstack overcloud deploy --stack test01 --templates openstack-tripleo-heat-templates/ -e openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml -e openstack-tripleo-heat-templates/environments/storage-environment.yaml -e openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml --ntp-server clock.redhat.com --control-scale 3 --compute-scale 3
2. Create a new image

Actual results:
Glance fails to connect to the Ceph cluster - Glance cannot function with its default store

Expected results:
Glance functions properly, and sets with the user and pool that were configured in puppet-ceph-external.yaml
Comment 5 Yogev Rabl 2016-03-06 04:31:00 EST
verification failed on openstack-tripleo-heat-templates-0.8.8-2.el7ost.noarch

The user and the pool are still reconfigured
Comment 10 Giulio Fidente 2016-03-23 09:27:03 EDT
Thanks Yogev, we need one more change to THT. Updating the external references.
Comment 12 Yogev Rabl 2016-04-04 10:12:01 EDT
verified on 
openstack-tripleo-heat-templates-0.8.14-5.el7ost.noarch
Comment 14 errata-xmlrpc 2016-04-07 17:47:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.