Bug 1308895 - [RFE] Support remove-old option on hammer level in Satellite 6.2
[RFE] Support remove-old option on hammer level in Satellite 6.2
Status: CLOSED DUPLICATE of bug 1215672
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.1.6
All All
medium Severity medium (vote)
: GA
: --
Assigned To: Katello Bug Bin
Katello QA List
: FutureFeature
Depends On:
Blocks: 260381 GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker
  Show dependency treegraph
 
Reported: 2016-02-16 06:54 EST by Jindrich Novy
Modified: 2017-04-25 12:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 15:53:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jindrich Novy 2016-02-16 06:54:08 EST
Description of problem:
There will be a new Pulp in Satellite 6.2 supporting 'remove-old' flag for repositories which allows to publish only packages which are present in the upstream repository. So once they are deleted upstream they will also vanish from published content.

Since this feature is new to Satellite's Pulp it would be nice if hammer understands this option as well so that hammer created repositories needn't to be amended via pulp-admin afterwards.

Nice feature would be to have an UI element in Satellite whether this option is enabled or disabled for a particular repository.

Version-Release number of selected component (if applicable):
6.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Brad Buckingham 2016-04-19 15:53:15 EDT
Thanks for creating the bugzilla request.

Satellite 6.2 will introduce a feature referred to as 'mirror on sync'.  It will ensure that the repository synced to Satellite will mirror the remote repository.  The solution for this one is covered by bug 1215672; therefore, I am going to mark this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1215672 ***

Note You need to log in before you can comment on or make changes to this bug.