Bug 1308900 - build: fix build break
build: fix build break
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Prasanna Kumar Kalever
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 07:07 EST by Prasanna Kumar Kalever
Modified: 2016-06-16 09:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:57:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanna Kumar Kalever 2016-02-16 07:07:01 EST
Description of problem:
fix broken build

$ cd ~/work/glusterfs/libglusterfs/src
$ make libglusterfs_la-y.tab.lo
  CC       libglusterfs_la-y.tab.lo
gcc: error: ./y.tab.c: No such file or directory
gcc: fatal error: no input files
compilation terminated.
Makefile:1391: recipe for target 'libglusterfs_la-y.tab.lo' failed
make: *** [libglusterfs_la-y.tab.lo] Error 1

Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-16 07:08:02 EST
REVIEW: http://review.gluster.org/13455 (build: fix broken build) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 2 Vijay Bellur 2016-02-16 07:32:46 EST
REVIEW: http://review.gluster.org/13455 (build: fix broken build) posted (#2) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 3 Vijay Bellur 2016-02-16 13:00:50 EST
REVIEW: http://review.gluster.org/13455 (build: fix broken build) posted (#3) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 4 Vijay Bellur 2016-02-17 08:25:09 EST
COMMIT: http://review.gluster.org/13455 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit a47d1bf91bfc8e9dcd35c2d3019e8e98dd4a7f83
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Tue Feb 16 17:29:31 2016 +0530

    build: fix broken build
    
    fix broken build introduced in
    commit "c458433041aafb48ae6d6e5fcf3e1e737dc3fda3"
    
    issue:
    
    $ make
      CC       libglusterfs_la-y.tab.lo
      gcc: error: ./y.tab.c: No such file or directory
      gcc: fatal error: no input files
      compilation terminated
    
    Change-Id: I9632444e733812d633960b15a4dbc7d299d2f44b
    BUG: 1308900
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/13455
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 5 Mike McCune 2016-03-28 19:22:56 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Niels de Vos 2016-06-16 09:57:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.