Red Hat Bugzilla – Bug 1308906
python-migrate: broken dependency with python-pbr
Last modified: 2016-09-19 22:49:23 EDT
Description of problem:
In EPEL we have python-migrate-0.9.2-2.el7.noarch which requires python-pr in version >=0.5.21,<1.0 but python-pbr is only available as python-pbr-1.8.1-2.el7.noarch.
Please note that this dependency is only set in requirements.txt for python in the package sources and not as an installation dependency for the rpm.
Using a WSGI script raises an exception:
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 626, in resolve
Version-Release number of selected component (if applicable):
Installation of source rpms and check requirements.txt fpor python-migrate.
Broken dependency with current version of python-pbr.
python-migrate should work with the version of python-pbr we hae in EPEL.
I would suggest to add a "Requires" tag in the .spec file of python-migrate for python-pbr in this case because in fact there's a dependency described above.