Bug 1308914 - v2v: webadmin does not indicate bootable/OS disk on an imported VM.
v2v: webadmin does not indicate bootable/OS disk on an imported VM.
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.3
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.5
: 3.6.5.3
Assigned To: Shmuel Melamud
Nisim Simsolo
:
Depends On: 1297202
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 07:59 EST by Nisim Simsolo
Modified: 2016-04-21 10:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:36:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: blocker+
mgoldboi: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
vdsm log with "debug" enabled (833.00 KB, application/x-xz)
2016-02-16 08:05 EST, Nisim Simsolo
no flags Details
screenshot (163.92 KB, image/png)
2016-02-16 08:05 EST, Nisim Simsolo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55321 master MERGED v2v: Set disk's boot flag after conversion 2016-03-28 09:50 EDT
oVirt gerrit 55357 ovirt-engine-3.6 MERGED v2v: Set disk's boot flag after conversion 2016-03-29 06:30 EDT
oVirt gerrit 55674 ovirt-engine-3.6.5 MERGED v2v: Set disk's boot flag after conversion 2016-04-06 11:16 EDT

  None (edit)
Description Nisim Simsolo 2016-02-16 07:59:40 EST
Description of problem:
In a continuation to bug: https://bugzilla.redhat.com/show_bug.cgi?id=1297202
After importing VM from VMware environment, there is no indication in RHEV webadmin for VM bootable disk.
This issue may be confusing when importing VM with more than one disk.
Observing vdsm.log shows that virt-v2v set bootable disk correctly for imported VM (ovf:boot='True')

Version-Release number of selected component (if applicable):
rhevm-3.6.3.1-0.1.el6
libvirt-client-1.2.17-13.el7_2.2.x86_64
vdsm-4.17.20-0.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64

How reproducible:
Consistently

Steps to Reproduce:
1. Browse webadmin and import VM with multiple disks from VMware.
2. After import has been completed, run VM and verify it runs properly (VM OS is running).
3. navigate to virtual machines tab --> select imported VM --> disks tab

Actual results:
None of the disks are marked with "OS" icon.
Edit disk --> "Bootable" checkbox is unchecked for all VM disks.

Expected results:
"OS" icon should appear on the VM bootable disk.
"bootable" checkbox should be checked for VM bootable disk.

Additional info:
Screenshot and vdsm.log attached,
for VM OVF file see log line created at: 2016-02-16 12:06:00,841
Comment 1 Nisim Simsolo 2016-02-16 08:05 EST
Created attachment 1127599 [details]
vdsm log with "debug" enabled
Comment 2 Nisim Simsolo 2016-02-16 08:05 EST
Created attachment 1127600 [details]
screenshot
Comment 3 Michal Skrivanek 2016-02-17 05:52:50 EST
Shmuel, fix in bug 1297202 is good enough to make things work, but in order to finish it completely it should correctly be represented within RHEV - so the disk should be flagged in the DB as well
Comment 4 Mike McCune 2016-03-28 19:36:13 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Eyal Edri 2016-03-31 04:35:30 EDT
Bugs moved pre-mature to ON_QA since they didn't have target release.
Notice that only bugs with a set target release will move to ON_QA.
Comment 6 Michal Skrivanek 2016-04-01 07:58:52 EDT
backport to ovirt_engine-3.6.5 needed
Comment 7 Nisim Simsolo 2016-04-13 06:48:16 EDT
Verified using VMware VM with 21 disks, bootable "OS" icon appears next to the correct bootable disk.
rhevm-3.6.5.3-0.1.el6
qemu-kvm-rhev-2.3.0-31.el7_2.10.x86_64
vdsm-4.17.26-0.el7ev.noarch
libvirt-daemon-1.2.17-13.el7_2.4.x86_64
sanlock-3.2.4-2.el7_2.x86_64

Note You need to log in before you can comment on or make changes to this bug.