Bug 1308915 - In text mode System to upgrade screen crops text when used with encrypted disk
In text mode System to upgrade screen crops text when used with encrypted disk
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.8
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks: 1286535
  Show dependency treegraph
 
Reported: 2016-02-16 08:03 EST by Alexander Todorov
Modified: 2017-12-06 05:43 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:43:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (270.39 KB, image/png)
2016-02-16 08:03 EST, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2016-02-16 08:03:09 EST
Created attachment 1127597 [details]
screenshot

Description of problem:

When performing a second install on a system with encrypted disk anaconda asks you whether you want to do a fresh install or upgrade the existing system. In text mode some of the text is cropped out of the screen, see attached screenshot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create system with encrypted disk. I have

swap - encrypted on raw partition
2 raid members, encrypted forming /dev/md0 formatted as PV
1 PV encrypted
1 VG, containing 1 LV for /, also encrypted

2. Start a second install, pass "text" on command line
3. 

Actual results:
When anaconda reaches the screen "System to upgrade" some of the text is cropped out.

Expected results:
All text is visible

Additional info:

The problem seems to be that the root partition is identified via UUID and is too long. If I use a default LVM + encryption partitioning after entering the passphrase in anaconda it shows the root volume as /dev/VolGroup-lv_root which
fits nicely into the screen.
Comment 2 Jan Kurik 2017-12-06 05:43:30 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.