Bug 1308936 - System shows '1 action' while no actions available
System shows '1 action' while no actions available
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Red Hat Access (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: Lindani Phiri
Satyajit Bulage
ui:access
:
: 1308938 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 09:10 EST by Vadim Rutkovsky
Modified: 2017-08-21 09:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:02:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (28.80 KB, image/png)
2016-02-16 09:10 EST, Vadim Rutkovsky
no flags Details

  None (edit)
Description Vadim Rutkovsky 2016-02-16 09:10:08 EST
Created attachment 1127607 [details]
Screenshot

Description of problem:
System with no actions to perform still has an icon with '1 Action' title on Systems tab of Red Hat Insights

Version-Release number of selected component (if applicable):
cfme-5.5.2.4-1.el7cf.x86_64
rh-ruby22-rubygem-redhat_access_cfme-0.0.7-1.el7cf.noarch

How reproducible:
Always

Steps to Reproduce:
1. Subscribe an appliance and a latest updated rhel6 Vm to the same account
2. Run SSA on VM
3. Check 'Red Hat Insight' - 'Systems'
   The system has a warn icon with '1 Action' title
4. Click on the warn icon
   A panel with 'no action' appears
5. Check the warn icon title
   The systems has a warn icon with '0 Actions' title
6. Click 'Without actions' button
   The system is listed, has a warn icon with '0 Actions' title
7. Click "With actions" and "Without actions" again
   The system is listed, has an OK icon with '0 Actions' title

Actual results:
Icons are not changed as expected

Expected results:
Icons are changed when an according tab is opened

Additional info:
Comment 2 Dave Johnson 2016-02-18 09:48:00 EST
*** Bug 1308938 has been marked as a duplicate of this bug. ***
Comment 4 Dave Johnson 2016-09-27 17:07:35 EDT
Satyajit, please review these and potentially redirect to Niyaz as appropriate.
Comment 5 Chris Pelland 2017-08-21 09:02:52 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.