Bug 1308940 - local-ipv4 requests against the ec2 metadata service return both instance and controller IPv4 addresses.
local-ipv4 requests against the ec2 metadata service return both instance and...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
5.0 (RHEL 7)
x86_64 Linux
medium Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: Lee Yarwood
Prasanth Anbalagan
: ZStream
Depends On: 1192087 1308941
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 09:13 EST by Lee Yarwood
Modified: 2016-03-08 12:09 EST (History)
14 users (show)

See Also:
Fixed In Version: openstack-nova-2014.1.5-26.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1192087
Environment:
Last Closed: 2016-03-08 12:09:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1334857 None None None 2016-02-16 09:13 EST
Red Hat Knowledge Base (Solution) 1585503 None None None 2016-02-16 09:13 EST
OpenStack gerrit 104138 None None None 2016-02-16 09:13 EST

  None (edit)
Comment 3 Prasanth Anbalagan 2016-03-03 10:25:27 EST
Verified as follows - only instance ip address is returned while accessing local-ipv4 metadata

**********
Version
**********

[root@lynx13 ~(keystone_demo)]# yum list installed | grep openstack-nova
openstack-nova-api.noarch        2014.1.5-27.el7ost      @rhelosp-5.0-el7-puddle
openstack-nova-cert.noarch       2014.1.5-27.el7ost      @rhelosp-5.0-el7-puddle
openstack-nova-common.noarch     2014.1.5-27.el7ost      @rhelosp-5.0-el7-puddle
openstack-nova-compute.noarch    2014.1.5-27.el7ost      @rhelosp-5.0-el7-puddle
openstack-nova-conductor.noarch  2014.1.5-27.el7ost      @rhelosp-5.0-el7-puddle
openstack-nova-console.noarch    2014.1.5-27.el7ost      @rhelosp-5.0-el7-puddle
openstack-nova-novncproxy.noarch 2014.1.5-27.el7ost      @rhelosp-5.0-el7-puddle
openstack-nova-scheduler.noarch  2014.1.5-27.el7ost      @rhelosp-5.0-el7-puddle
[root@lynx13 ~(keystone_demo)]# 

**********
Logs
**********

[root@lynx13 ~(keystone_demo)]# nova list
+--------------------------------------+----------+--------+------------+-------------+--------------------------------+
| ID                                   | Name     | Status | Task State | Power State | Networks                       |
+--------------------------------------+----------+--------+------------+-------------+--------------------------------+
| ee202949-7098-48f4-a10b-f1286b469311 | demo-vm1 | ACTIVE | -          | Running     | private=10.0.0.4, 172.24.4.229 |
+--------------------------------------+----------+--------+------------+-------------+--------------------------------+


Metadata access from VM
=======================
$curl -q http://169.254.169.254/2009-04-04/meta-data/local-ipv4
10.0.0.4$
$
$curl -q http://169.254.169.254/2008-09-01/meta-data/local-ipv4
10.0.0.4$
$
Comment 5 errata-xmlrpc 2016-03-08 12:09:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0361.html

Note You need to log in before you can comment on or make changes to this bug.