Bug 1308960 - Newly added parameters (PARTITION_EVENT_PURGE and RESOURCE_CONFIG_HISTORY_PURGE) do not have a description and it seems they do not work
Newly added parameters (PARTITION_EVENT_PURGE and RESOURCE_CONFIG_HISTORY_PUR...
Status: CLOSED DUPLICATE of bug 1290436
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server (Show other bugs)
JON 3.3.5
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michael Burman
Mike Foley
:
Depends On: 1308963
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 10:06 EST by bkramer
Modified: 2016-02-17 11:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 11:45:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2016-02-16 10:06:12 EST
Description of problem:
In System Settings page in JBoss ON 3.3.5 there are two new parameters: PARTITION_EVENT_PURGE and RESOURCE_CONFIG_HISTORY_PURGE. These parameters are mandatory but by default their value is not set. Also, although, we can assume what the meaning of these parameters are, there are no description on the page. 

When setting both parameters to 1 - I assumed that all partition events older then a day would be deleted. However, this is not a case. 

Version-Release number of selected component (if applicable):
JBoss ON 3.3.5

How reproducible:
Always

Steps to Reproduce:
1. Install JBoss ON 3.3.5
2. Navigate to JBoss ON UI -> Administration -> System Settings and set PARTITION_EVENT_PURGE and RESOURCE_CONFIG_HISTORY_PURGE to 1;
3. Save newly added values (having in mind a workaround from the Bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1290436);
4. Wait for the Data Purge Job;

Actual results:
Nothing has been deleted. To confirm this, navigate to JBoss ON UI -> Administration -> Partition Events and confirm that the Total Rows number is not changed;

Expected results:
All events older then a day are deleted.


Additional info:
Comment 1 bkramer 2016-02-17 11:45:23 EST

*** This bug has been marked as a duplicate of bug 1290436 ***

Note You need to log in before you can comment on or make changes to this bug.