Bug 1308966 - only object storage can be created
Summary: only object storage can be created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2
Assignee: sankarshan
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-16 15:23 UTC by Lubos Trilety
Modified: 2016-08-23 19:47 UTC (History)
3 users (show)

Fixed In Version: rhscon-ui-0.0.19-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
page shown during OpenStack Storage creation (35.37 KB, image/png)
2016-02-16 15:23 UTC, Lubos Trilety
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-02-16 15:23:25 UTC
Created attachment 1127617 [details]
page shown during OpenStack Storage creation

Description of problem:
UI provides another types of storage like block and OpenStack storages however they cannot be created.
For block storage next button is not working at all. For OpenStack storage the button works, but next page is wrong. There's 'Create Storage' button though, but it doesn't do anything.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-2.el7.x86_64
rhscon-ceph-0.0.6-2.el7.x86_64
rhscon-ui-0.0.12-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open Storage page and click on 'Add Storage' button
2. Choose that 'Block Storage' should be created
3. Click on 'next' button

Actual results:
Nothing happens

Expected results:
A page with storage configuration is shown

Additional info:

Comment 2 Jeff Applewhite 2016-03-18 17:32:26 UTC
OpenStack storage is out of scope now but on the recent build I encountered the failure of RBD creation (after it initially worked). I had previously created / deleted an red and then it stopped working. High Prio fix

Comment 3 Kanagaraj 2016-03-20 08:02:10 UTC
Jeff, do you have logs of the setup? we can take a look

Comment 6 Lubos Trilety 2016-07-15 13:21:05 UTC
Tested on:
rhscon-ui-0.0.46-1.el7scon.noarch

ec and replicated pools can be created
red can be created
openstack storage is out of scope

Comment 8 errata-xmlrpc 2016-08-23 19:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.