Bug 1308971 - Dummy audio driver (no sound) after upgrade from F21 to F22, not fixed in F23
Dummy audio driver (no sound) after upgrade from F21 to F22, not fixed in F23
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 10:32 EST by Jobava
Modified: 2016-02-16 17:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 17:21:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jobava 2016-02-16 10:32:34 EST
Description of problem:
ASRock 960GC-GS FX desktop motherboard
Realtek ALC662 sound chipset that uses HDA audio

Version-Release number of selected component (if applicable):
4.3.5-300.fc23.x86_64+debug #1 SMP

How reproducible:
Not sure

Steps to Reproduce:
1. Have Fedora 21
2. Update to Fedora 22

Actual results: Sound doesn't work, all it shows is a 'dummy audio output' and no audio inputs.


Expected results: The sound should work and there should be at least two available audio drivers: the motherboard's and the graphics cards's HDMI output.


Additional info:

I upgraded from Fedora 21 to Fedora 22 and the sound went away. I then upgraded from F22 to F23 and I still have the same issue.

Is there a way to reset or reinstall the audio drivers?

A liveDVD Fedora 23 does have sound, it's just the upgrade killed it somehow.

The output of lshw
https://paste.fedoraproject.org/323501/63431714/raw/

I also deleted the pulseaudio configuration files in ~/.config/pulse
pulseaudio -k

The output of aplay -l:
aplay: device_list:268: no soundcards found...


The output of aplay -L:
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)


Any help is greatly appreciated!
Comment 1 Jobava 2016-02-16 10:33:43 EST
I should add that the sound still worked if I switched to the old F21 kernel, but no kernel from F22 and F23.

Unfortunately, I upgraded my system and now my old F21 kernel is gone.

Thanks
Comment 2 Jobava 2016-02-16 10:34:49 EST
A related bug may be this one: https://bugzilla.redhat.com/show_bug.cgi?id=1255070
Comment 3 Jobava 2016-02-16 17:21:09 EST
This was fixed by compiling a separate kernel with the config:

CONFIG_ACPI_REV_OVERRIDE_POSSIBLE

I don't understand why the Fedora-delivered kernel does not have this enabled.
Comment 4 Jobava 2016-02-16 17:22:17 EST
This is not a real fix, just a workaround, since asking people to compile their own kernel is not a solution generally applicable.

Note You need to log in before you can comment on or make changes to this bug.