Bug 1309097 - Undoing a custom preview with unselected disks, will cause that the unselected disks will be removed
Undoing a custom preview with unselected disks, will cause that the unselecte...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3.1
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Daniel Erez
Aharon Canan
Storage
: Automation, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 15:14 EST by Raz Tamir
Modified: 2016-03-10 07:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 07:47:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine and vdsm logs (1.69 MB, application/x-gzip)
2016-02-16 15:14 EST, Raz Tamir
no flags Details
screenshots (1.15 MB, application/x-gzip)
2016-02-17 06:27 EST, Raz Tamir
no flags Details

  None (edit)
Description Raz Tamir 2016-02-16 15:14:10 EST
Created attachment 1127720 [details]
engine and vdsm logs

Description of problem:
After undoing a custom preview of a snapshot, the unselected disks will be removed from the setup.


Version-Release number of selected component (if applicable):
rhevm-3.6.3.1-0.1.el6.noarch
vdsm-4.17.20-0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a vm with 2 disks
2. Create snapshot with the 2 disks
3. Custom preview the snapshot selecting the first disk from the new snapshot and the second disk from the Active VM snapshot
4. Undo the preview

Actual results:
The second disk will be removed from the setup

Expected results:


Additional info:
Comment 1 Allon Mureinik 2016-02-17 02:32:17 EST
Daniel, is this the behavior by design?
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-17 02:32:22 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Daniel Erez 2016-02-17 03:44:35 EST
Hi Raz,

Have you encountered the issue using the UI or from the rest-api? As using the UI it doesn't seem to reproduce. Can you please send the api commands or a screencast (if you used the UI).

Thanks!
Daniel
Comment 4 Raz Tamir 2016-02-17 06:27 EST
Created attachment 1127914 [details]
screenshots

Screenshots attached
Comment 5 Daniel Erez 2016-02-21 08:46:52 EST
Doesn't reproduce on latest 3.6.3 environments (both on R&D and QE). Moving to ON_QA.
Comment 6 Raz Tamir 2016-02-21 08:59:15 EST
Verified on rhevm-3.6.3-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.