Bug 1309128 - gcc 6.0 segfaults
gcc 6.0 segfaults
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 18:03 EST by Oliver Kurth
Modified: 2016-03-10 13:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 13:39:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source (392.06 KB, text/x-csrc)
2016-02-16 18:03 EST, Oliver Kurth
no flags Details

  None (edit)
Description Oliver Kurth 2016-02-16 18:03:06 EST
Created attachment 1127743 [details]
Preprocessed source

Description of problem:

gcc 6.0 segfaults when compiling open-vm-tools


Version-Release number of selected component (if applicable):
gcc version 6.0.0 20160205 (Red Hat 6.0.0-0.10) (GCC) 


How reproducible:
always


Steps to Reproduce:

git clone https://github.com/vmware/open-vm-tools.git
cd open-vm-tools/
cd open-vm-tools/
autoreconf -i
./configure --without-kernel-modules
make

Actual results:
appUtil.c: In function 'AppUtil_SendGuestCaps':
appUtil.c:54:1: internal compiler error: Segmentation fault
 AppUtil_SendGuestCaps(const GuestCapabilities *caps, // IN: array of capabilities
 ^~~~~~~~~~~~~~~~~~~~~
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccQQfF9H.out file, please attach this to your bugreport.


Expected results:


Additional info:
Comment 1 Marek Polacek 2016-02-17 04:19:01 EST
I can't reproduce this -- on which arch does this happen?
Comment 2 Jakub Jelinek 2016-02-17 04:42:29 EST
The dump is from x86_64.  But, I can't reproduce this either, with the same snapshot or even with the cc1 binary from the -0.10.fc24 rpm.
Comment 3 Oliver Kurth 2016-02-17 21:27:03 EST
Interesting. I did this in a docker container - I thought it wouldn't matter. I cannot reproduce this in a vm either. It's a slightly different version though:
gcc version 6.0.0 20160212 (Red Hat 6.0.0-0.11) (GCC)
Comment 4 Jan Kurik 2016-02-24 10:23:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Marek Polacek 2016-03-10 10:15:35 EST
Is this still a problem with latest GCC build?
Comment 6 Oliver Kurth 2016-03-10 13:25:48 EST
It looks like the issue is gone. The build with
gcc version 6.0.0 20160305
does not throw any segfault any more (I am getting other errors, but those are not related). It's in a container updated to the latest rawhide, everything else is the same as in my original report.
Comment 7 Marek Polacek 2016-03-10 13:39:50 EST
Great, thanks.  I think we can close this one now then.

Note You need to log in before you can comment on or make changes to this bug.