Bug 1309151 - RFE [HC] hosted_storage storage domain should not be visible when creating vdisks
RFE [HC] hosted_storage storage domain should not be visible when creating vd...
Status: CLOSED DUPLICATE of bug 1309150
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
future
x86_64 Linux
low Severity low (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks: Generic_Hyper_Converged_Host
  Show dependency treegraph
 
Reported: 2016-02-16 20:22 EST by Paul Cuzner
Modified: 2016-02-17 01:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
rhevm 3.6.3
Last Closed: 2016-02-17 01:20:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Paul Cuzner 2016-02-16 20:22:52 EST
Description of problem:
In a hosted engine environment, you need to import the hosted_storage storage domain for the hosted engine to be imported. However, once this is done you see this hosted_storage storage domain when ever you create vdisks.

Since the goal is to keep hosted_storage separate from user vm's this storage domain should be masked in the UI to provent users allocating vdisks to the 'management' storage domain.


Version-Release number of selected component (if applicable):
3.6.3

How reproducible:
Every time

Steps to Reproduce:
1. Import the hosted_storage
2. create a vm, and add a vdisk
3. note the targets for the vdisk allocation includes the hosted_storage domain

Actual results:
user can allocate vdisks to the hosted_storage domain

Expected results:
hosted_storage should not be available as a SD to select when creating (or moving) vdisks (in vm tab, or disks tab for example)



Additional info:
Comment 1 Michal Skrivanek 2016-02-17 01:20:53 EST

*** This bug has been marked as a duplicate of bug 1309150 ***

Note You need to log in before you can comment on or make changes to this bug.