Bug 130921 - tic's -C option converts "%%" incorrectly
Summary: tic's -C option converts "%%" incorrectly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ncurses   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Raszyk
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-25 19:37 UTC by Nalin Dahyabhai
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: ncurses-5.5 Release 10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 14:46:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ncurses-5.5-10.src.rpm (1.67 MB, application/x-rpm)
2005-12-23 14:45 UTC, Petr Raszyk
no flags Details

Description Nalin Dahyabhai 2004-08-25 19:37:58 UTC
When invoked with the -C flag to convert terminfo sources to the
termcap format, tic converts "%%" to "%%%".  Because both termcap and
terminfo use "%%" as an escape for a single "%", I think this is
incorrect.  This happens to the tvi921 terminal definition, for example.

Comment 1 Thomas E. Dickey 2004-08-28 00:29:07 UTC
will fix (thanks).

Comment 2 Thomas E. Dickey 2004-09-02 20:37:41 UTC
I fixed this (one-liner) in my 20040828 patch.

Comment 3 Petr Rockai 2005-02-28 08:46:45 UTC
Nalin, i would appreciate if you could try if the bug is really fixed in new 
version, so i can either close the bug or go figuring my way around it... 

Comment 4 Thomas E. Dickey 2005-11-14 00:07:23 UTC
It's in ncurses 5.5 anyway (perhaps Nalin will respond someday).

Comment 5 Nalin Dahyabhai 2005-11-14 19:29:37 UTC
Oops, yes, 5.5 appears to be doing the right thing here, thanks!

Leaving open because we haven't got 5.5 in Raw Hide yet.

Comment 6 Petr Raszyk 2005-11-21 08:39:55 UTC
I will upgrade and test ncurses this week.


Comment 7 Petr Raszyk 2005-12-23 14:45:07 UTC
Created attachment 122562 [details]
ncurses-5.5-10.src.rpm

Fixed in current release.
Sorry, I am too late.


Note You need to log in before you can comment on or make changes to this bug.