Bug 1309219 - "volume stop force" not stopping the volume when server quorum not met
"volume stop force" not stopping the volume when server quorum not met
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Mohit Agrawal
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 04:08 EST by Byreddy
Modified: 2016-07-14 01:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-14 01:50:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2016-02-17 04:08:53 EST
Description of problem:
=======================
Had a 4 node cluster with distributed volume with server quorum enabled and server quorum ratio set to 90 and brought down one of the node and tried to stop the volume using force option, volume stop not happening and it's failing with error message "quorum not met"


Version-Release number of selected component (if applicable):
==============================================================



How reproducible:
=================
Always


Steps to Reproduce:
===================
1.Create a four node cluster
2.Create and start  a distributed volume  and set the quorum ratio to 90  and enable the server side quorum.
3.Stop glusterd in one of cluster node
4.From one of glusterd running node, try to stop the volume using force option // it won't stop and fail with error message "Quorum not met"


Actual results:
===============
volume stop with force option is not stopping the volume  when server quorum  not met.


Expected results:
=================
Volume stop with force option should stop the volume when quorum not met.


Additional info:
Comment 2 Vijay Bellur 2016-07-13 05:57:48 EDT
REVIEW: http://review.gluster.org/14910 (glusterd:  "volume gluster stop/start force" does not stop/start the volume             when server quorum not met) posted (#1) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)
Comment 3 Vijay Bellur 2016-07-14 00:59:54 EDT
REVIEW: http://review.gluster.org/14910 (glusterd :  "gluster volume stop force" does not stop the volume             while quorum not met) posted (#2) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)
Comment 4 Atin Mukherjee 2016-07-14 01:50:14 EDT
When quorum is not met, volume becomes non-operational and in that case do we really mind to stop the volume? IMO, this is not a bug given there is no use case which demands bypassing the quorum check here. I am closing this bug with this explanation, feel free to reopen if you think otherwise with proper justifications.

Note You need to log in before you can comment on or make changes to this bug.