Bug 1309221 - UI- Add VM from template list - wrong "Optimized For" value
UI- Add VM from template list - wrong "Optimized For" value
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: jniederm
meital avital
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 04:16 EST by Fred Rolland
Modified: 2016-04-21 10:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Previously when VM was created from Templates tab using "New VM" option and the template had disks and "optimized for" was set to "Desktop" in template and "optimized for" field was not touched in New VM dialog then the disks of newly created VM used "Clone" provisioning (even though "Thin" provisioning is appropriate for "Desktop" VMs). Fix: Result: Disks of newly created VMs always have provisioning based on "Optimized for" (Desktop/Server) field.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:38:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
Log snippet (24.44 KB, text/plain)
2016-02-17 04:16 EST, Fred Rolland
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54775 master MERGED core: Provisioning of VMs created from Templates tab fix 2016-03-16 05:12 EDT
oVirt gerrit 54817 ovirt-engine-3.6 MERGED core: Provisioning of VMs created from Templates tab fix 2016-03-16 12:20 EDT

  None (edit)
Description Fred Rolland 2016-02-17 04:16:53 EST
Created attachment 1127893 [details]
Log snippet

Description of problem:
When adding a new VM from the "Templates" tab, the UI shows "Optimized For" as "Desktop" but it is created as "Server".

If you select "server" and then "Desktop" again, it will be created as "Desktop".

Version-Release number of selected component (if applicable):
4.0.0

How reproducible:
100%

Steps to Reproduce:
1. Go to "Templates" tab, select a template
2. Click "New VM"
3. Add a name for the VM and click OK

Actual results:
The VM is created as "Server" (Clone/Independent)

Expected results:
The VM is created as "Desktop" (Thin/Dependent)

Additional info:
Comment 1 Michal Skrivanek 2016-02-22 07:54:53 EST
dupe of bug 1298231 (or the other way around)?
Comment 2 Tomas Jelinek 2016-02-22 09:44:26 EST
nope, this is a different issue - the 1298231 is a about the "new disks dialog" inside the VM dialog.

This bug is about the template disks provisioning. It happens only in the "new VM" created from the templates tab - it seems the template is not properly inited in this particular flow.
Comment 3 meital avital 2016-04-12 04:59:02 EDT
Verified rhevm-3.6.5.1-0.1.el6

Verify steps:
1. Go to "Templates" tab, select a template
2. Click "New VM"
3. Add a name for the VM and click OK
4. The VM created as "Desktop"

Note You need to log in before you can comment on or make changes to this bug.